View Single Post
      08-24-2011, 12:18 AM   #14
gizmo335i
Colonel
 
gizmo335i's Avatar
 
Drives: 08 JB E92 335i 6MT
Join Date: Oct 2009
Location: San Antonio

Posts: 2,907
iTrader: (50)

Garage List
2008 E92 335i  [4.73]
Man, I am almost the EXACT same as you. Same car, same miles. Mine is at the dealer now. I should be hearing back today sometime.

This is rediculous. If this can't be fixed, I will not keep this car. I can't deal with squeaks. I have owned a lot of cars and none of them had this problem. This should not be something you have to "Deal" with.

My dealer definately did not tell me this was not covered under warranty. They gave me no hastle at all and gave me a new Z4 as a loaner.

My SA told me there is a TSB that the brake pads should be changed sooner than in the past. Once they get down to 7.5mm. And that they are aware brake squealing is a common issue with these cars. And he said he's aware that it could be the sensor. One thing about this dealer here, they have been very good to me so far.

The scary thing for me is that I had NO noise before I had my coils installed. I know one has nothing to do with the other...but it's still a strange coincidence to me.

The only thing that has me hoping mine could be fixed is that my problem I think is a little different than your's and what everyone else is explaining on here. Mine only makes noise when pressing the brake. And it's only coming from the front driver's side.

I'll let you know what happens as soon as I get it back. I may be driving a new truck soon....
__________________
JB4 | Vanguard/Quad burnt tips | Linea Corse | Mtech Front/rear | AFE DCI | H&R Sport + Koni yellow | Umnitza Full LED Angels | Akyrm lip/quad diffuser | Alpine CSL CF Trunklid
See Garage for more
gizmo335i is offline   United_States
0
Reply With Quote