View Single Post
      08-26-2011, 04:14 PM   #1
axis
First Lieutenant
 
Drives: 2011 Steel Gray C 300
Join Date: Dec 2010
Location: Florida

Posts: 343
iTrader: (2)

Problem with my car after resetting adaptations in INPA

OK This is going to be a long post, but I'd like to try and provide as much detail on the issue I'm having as possible from the getgo.

So I decided I wanted to reset all the engine adaptation values on my car to let it start fresh. I reset them using INPA with the engine off, ignition on. When I started my car back up, I got the orange half engine error on my cluster but the engine seemed to be running fine. Thinking that maybe I just needed to clear an error, I looked and sure enough there were two stored errors related to the DME/DDE. I cleared the codes, and the light went away. I shut down the car, and started it back up to see if the problem was gone. Unfortunately, the same error popped up again on the display.

After that, I thought well maybe the car just needs to drive around a little to relearn a value and that will fix it. I drove around the block and everything seemed fine. If the engine had reduced power, I wasn't really able to tell. I did notice that the exhaust note seemed more audible in the car though. I got back home and shut it down.

About 10 minutes later, I went out to start my car because I needed to go pick up my gf and the same error popped up but this time the engine was revving up and down on its own over and over and pressing the gas pedal did nothing at all. I shut it down, restarted, same thing. I checked the codes again and there were 3 errors in the DME/DDE section again. I cleared them once more, shut down, and this time the engine did start and ran smoothly but the half engine light was still there.

I decided I would try resetting the adaptation values again, this time with the eigine running, just to see if that made a difference. The problem was, now INPA wasn't able to reset the values. I got an error ERROR_ECU_CONDITIONS_NOT_CORRECT_OR_REQUEST_SEQUEN CE_ERROR

I thought maybe i had a bad connection or something so I shut down INPA, restarted, and tried again and got the same result. I then tried it with the engine off, same result. Now I have no idea what to do to fix this. The car was working fine before clearing the adaptations, and I didn't think it was possible to do any damage to the car by resetting them. Any ideas? Right now I have the battery negative cable disconnected in hopes that it will reset the ECU and fix it but I don't know if it is going to work or not. Any help would be greately appreciated. Thanks!
axis is offline   United_States
0
Reply With Quote