View Single Post
      09-06-2011, 11:46 PM   #1
sunpole
Private
1
Rep
71
Posts

 
Drives: X5, 335i
Join Date: Jul 2010
Location: Houston

iTrader: (0)

E92 Jehnert upgrade total disaster, need your help!

Guys, I need your help...

Over the Labor day weekend, I finally put together my upgrade project - the full Jehnert flatline series + XD600/6 amp. I was expecting an easy installation, but it turned out to be a total disaster, well not entirely, I'm happy with the underseat bass as it is full and punchy.

But the good news end here... There are 2 problems,

- A constant white noise coming from the door speakers and tweeters even when the volume is turned off, I had to adjust the gain all the way to 0 to alleviate this.
- When playing any kind of percussion high pitch sound, it sound harsh, noisy, pronounced and dispersed, I don't how else to describe it, on a lot of the songs it is unbearable when playing at any level of loudness. This can't be normal! Are my tweeters defective?? Do you think this could be the same as the white noise problem?

Needly to say I am very disappointed at the moment, with time and $$$ premium I paid for the speakers... Can someone tell me what's wrong and how to fix this??

One thing worth mention is I stripped the crossover box to bare circuit so it would fit on the door, I hope that is not the cause, other than that I did a pretty standard installation following what the experts have already done on this forum.

- HiFi HU -> Technic's harness -> XD600
- ch1,2 for front, bridged ch3,4 and ch5,6 for the underseats respectively
- 4 gauge wire for power connection nice and secure. Tried both battery ground and left rear seat ground, but result the same.
- when unplug Technic's RCA inputs from the amp, hissing noise gone, but of course that's the only source input I can't do without it...

Thanks for looking!