View Single Post
      06-20-2007, 03:50 PM   #1
JayClay32
Hook'em Horns
 
JayClay32's Avatar
 
Drives: Titanium Silver
Join Date: Apr 2007
Location: SoCal

Posts: 127
iTrader: (0)

PROcede's Here!.... Well almost?

So I’ve been tracking my PROcede since Monday counting the days till it was delivered. I woke up this morning and checked the progress before I headed into work, and to my delight I found that it was out for delivery One day early. When I got to work I told the mailroom that I was expecting a package and to give me a call when it got in and I’d go pick it up. Well at about 10am our mail guy came by with the UPS packages and said that he didn’t have one for me. WHAT!? So I go back online and the UPS tracking page still said "Out for Delivery". "So maybe it was on a different truck" I thought to myself and continued to wait. At about 11am I checked again and the info said "DELIVED"! I thought "Great let me call the mailroom." When I called they checked and said “Sorry no package" and offered to call UPS for me and find out what was going on. After 5 minutes I get a call back from the mailroom. They told me the UPS delivered it to the wrong address! They told me that I would have to call UPS to get them to pick it up from the wrong place and bring it to me. So I sit here waiting for UPS to get me my PROcede.

The reason this really pisses me off is b/c early this year I sold a set of Rinspeeds off my old Range Rover Sport. Not only did FedEx misplace them but they lost one rims and caused server damage to the other three. This is not my year for shipping and receiving.:mad:
__________________
"Drive it like you stole It!"
2007 E90 335i|BLACK LEATHER|6MT|PREMIUM PKG|SPORT PKG|ACTIVE STEER|COMFORT ACCESS|NAV|BBS RG-R 19x9F 19x10.5R|KW V2 COILOVERS|H&R SWAY BARS|IPOD INTERGRATION|Hüper Optik Tint 60% WINDSHIELD 40% ALL AROUND|
JayClay32 is offline  
0
Reply With Quote