View Single Post
      12-12-2011, 06:11 AM   #21
EQUANT
First Lieutenant
4
Rep
310
Posts

 
Drives: 320d
Join Date: Dec 2009
Location: Bucharest

iTrader: (0)

As i said in earlier posts, i have replaced the front belt and all the tensioners (including crank vibration damper) under warranty and the noise returned after no more than 3000km.

Took the car back to BMW and they admitted it's a belt problem (the one that i have is an old model of belt (it was replaced this summer) and it slips on one of the rollers while the load increases - full lock). Talked to a service guy and he mentioned a case in which they replaced the belt 5-6 times on an X3 and the noise kept returning. He said that the last time they did that, BMW had sent a new/improved belt model and that one should work fine.
I will get mine replaced (again) and hopefully they will mount the new belt design and the noise will not return.

Other than the sound discomfort, there is no danger running the car as it is. Post a youtube video if you can, that way i can tell you if it's the same noise as mine.

Cheers,

LE: BMW has replaced (again) the vibration pulley under warranty, but car still does the same noise. They said that for my model there isn't a newer belt part no. so they didn't replace it. They are unable to pinpoint what's causing the noise. I've learned to accept the noise, and avoid doing full locks (still annoying, though)
__________________
BMW 320 dA LCI, BMW PPK - 197HP, 2010, sapphire black, steptronic

Last edited by EQUANT; 04-22-2012 at 06:07 PM.