View Single Post
      12-25-2011, 06:54 PM   #1
farb
teh Rider!
 
Drives: E92 335xi
Join Date: May 2011
Location: Toronto

Posts: 453
iTrader: (1)

I just wanted to share my own experience with ModMy3.com Company.
So on Nov.7 I place my order for a LED interior kit + side turn signal bulbs all in white, for my e92. Transaction went smooth, I got the confirmation that my package is on its way. About two weeks later I get my package, looks all good, everything seems to be there.

A week later I found some free time to tackle the installation. I installed the trunk, driver and passenger foot well bulbs and rear console lights. I noticed after installation that one of the rear console small T10 LED does not light up, no matter how I plugged it in, turned it a couple of time, tried other sockets, nothing . I ignored the faulty bulb and continued with the rest.

Next I tackled the rear dome light + map lights. I had ordered the No-Ghetto dome lights so I was really excited to see how they look!

So after a lot of twisting and turning and pushing of the LED panel into the socket, I figured out there must something wrong with the panel because the base wouldn't go into the socket, it was just too big!

That's where I contacted ModMy3 guys for support with this and also I told them about the faulty LED.

David was the guy who responded and he suggested flipping the LEDs because he said the LEDs are bi-polar. I was already aware of that.
I also told him about the LED panel for the rear dome light not fitting the socket. Thatís where he suggested pushing it in really hard, all the way in. The second time I gave it a try, I use all of the force to push the panel straight into the socket. But the panel did not go in at all because the soldiers at the base of the panel made it too big for the socket and it actually broke right at the base.

Long story short, I've been trying to find out a possible to this problem from ModMy3.com and they're been absolutely terrible at responding to my emails. Looks like as soon as I told them that something broke, they all got scared and stopped responding to my emails ?!! All I wanted from them is to discuss what can be done about this problem! Its been a month now that they've stopped responding to my emails even though I send them reminders weekly about this problem.

I just want to warn people who might be considering their products to be extra careful with this as they're all supportive when you're paying but when time comes for support and defective products, they fail terribly
farb is offline   Canada
0
Reply With Quote