View Single Post
      04-24-2012, 08:53 AM   #280
MTP335
First Lieutenant
8
Rep
377
Posts

 
Drives: 2011 E90 335i Xdrive Msport
Join Date: Mar 2011
Location: NYC

iTrader: (0)

Quote:
Originally Posted by Sam335ix View Post
Ok... Mine sounds good but at higher RPM.. at lower rpms it sounds strange, hard to explain it but its almost like one giant loud wet fart lmao... WTF is this normal? I have JB4, DP's Charge pipe and and now the BMS intake. The wooooshing sound is cool but the other sound getting to the woooshing part is really annoying as if something is loose and air is leaking.
Quote:
Originally Posted by myfly335 View Post
THAT IS THE SAME PROBLEM I HAVE I TOLD THEM AND THEY SAID THAT CAN I SEND THEM PICTURES I HEAR THE SAME SOUND I TOOK IT OUT AND INSTALLED IT 3 TIMES ALREADY THE SOUND GOES AWAY FOR 1-2 HOURS BUT AFTER DRIVING AROUND THE SAME SOUND... I THINK SOMETHING KEEPS LOOSING ITSELF...BECUZ ITS OK WHEN I REINSTALL IT FOR A COUPLE HOURS..
Quote:
Originally Posted by mdyates View Post
Dude, I am seriously lmao'!! I thought the same thing with my Afe. This n55 sounds weird as shit (no pun intended) with intake. Turn your lag fix to 100 and it sounds like a quiffe Everytime you give partial throttle..
Quote:
Originally Posted by Sam335ix View Post
So Mike, what gives man? What is the sound we are all hearing? What can be done to fix it? Otherwise I would like to return mine because the sound is a huge turn off.
Can someone post a vid or sound clip? thx
__________________