View Single Post
      05-14-2012, 04:00 AM   #39
kiwi29
Team iTouge
 
kiwi29's Avatar
 
Drives: 09 M-Tech 328i
Join Date: Jul 2011
Location: Long Beach, CA

Posts: 2,074
iTrader: (9)

Quote:
Originally Posted by JT_Munkey View Post
Highly doubt it's coolant since that's easily replaceable -- even with water. Typically when pushed your fan will blow for a short period of time depending on how hard you pushed it. When I ran 100% throttle re-map on my BMS tune, one block around neighboring side roads caused my fan to turn on. Bottom line is that those two things are definitely something you gotta ask your SA about but for sure you're gonna have to replace it soon.I would also suggest having them check for leaks as well since my oil housing gasket needed to be replaced ~1k BEFORE my tstat and water pump went out.
I honestly feel a bit assed out, I don't have an SA anymore and I'm out of warranty :'( I don't seee any leaks and my fan only stays on for about 10 seconds and shuts off. It doesn't always turn on but it usually does after I run a few times in the canyons and drive back home. The other times it turns on is from a dead cold start and I drive right away. Other than that, I've only had one over heated problem and I've only put an eight of distilled water in the antifreeze resevoir to make it reach back to max. But definitely ill try to get an expert's help
__________________
Quote:
Originally Posted by The HACK View Post
I'm going to use a very simple analogy, I hope you'll understand.
Driving is like having sex.
It really is. You can read up all you want about how to please a woman, you can look at all the diagrams in the world, but just like the clitoris, you won't know what the hell an apex is before you actually find it.
kiwi29 is offline   United_States
0
Reply With Quote