View Single Post
      08-27-2012, 08:12 AM   #725
Robspages
0
Driver
 
Drives: 2009 Alpine White 335d
Join Date: Jul 2012
Location: Atglen,PA

Posts: 24
iTrader: (0)

Quote:
Originally Posted by A13x View Post
OK i think your onto something as the only thing i can think i changed was the modem on my phone, maybe the kernal too but i have since reset it and also tried three modems but cannot find the working version.

I made a post here:
http://www.e90post.com/forums/showthread.php?p=12570819

I am now tempted to go through every modem until i get the damn thing to work. Maybe its this which is causing the problem
I had a similar problem with my T-Mobile G2 sending contacts to my 09 335D's iDrive. I just got an S3 this weekend and the same fix worked for my Galaxy S3 as for the G2.

It sounds like a PITA but it's a one-time thing, so bear with me.

On your phone, go to System Settings -> Application Manager.

Click on the Running tab, then locate the Bluetooth service(s) and click on it.

Find the BluetoothPbapService. This is the service which handles sharing your contacts. Click Stop, and at the confirmation prompt, confirm that you want to stop this service.

Your car should now be able to get your contacts out. If you reboot your phone, the service will be running again, but your car will still be able to access the contacts.

I have no idea why this is necessary, but it worked like a charm for my G2 and now my Galaxy S3.

good luck.
Robspages is offline  
Appreciate 0
Reply With Quote