View Single Post
      09-04-2012, 09:01 PM   #1
bmwe91
New Member
0
Rep
13
Posts

 
Drives: 07 e91 328xi
Join Date: Mar 2012
Location: New Britain CT

iTrader: (0)

Replacing Instrument Cluster-Need Help

Ok so I searched a ton on google, and on the forums here but I couldn't find an accurate and definite answer.

Here's the deal, my cluster was showing -40 for the outside temperature. After a ton of research I found out that if the cluster is showing -40 it means that there is an open circuit. First off, I tried replacing the outside temp sensor which didn't work. I then went ahead and checked resistance and all that at the sensor plug, on the sensors two cables where the sensor and headlight wiring meet up, on the plug from the junction box that goes straight to the instrument cluster, and on the plug that connects to the instrument cluster. All wiring showed good connection. I think this is the instrument cluster, since there is a very big chance the cluster went bad because my vehicle once had problems where the vehicles electrical system got too much voltage from a jump and the CAS had to be replaced.

Now for the question, I bought a used instrument cluster off ebay. The cluster is off a 2008 328i with navigation. My car is a 2007 328xi without navigation. When I plug the new cluster in, will i still have my old mileage? Also, will there be any error codes? If there are any problems because of the navigation and the 2 wheel drive will it be possible to recode the cluster to non-navi and 4 wheel drive?

PLEASE HELP AND ALL HELP APPRECIATED