View Single Post
      09-25-2012, 08:21 AM   #49
MrQuickR1
Second Lieutenant
4

 
MrQuickR1's Avatar
 
Drives: 2011 328i
Join Date: Jan 2012
Location: NJ


Posts: 284
iTrader: (0)

Quote:
Originally Posted by Three_thirty_I View Post
Resurrecting this thread since I am experiencing some of these same problems to a certain degree and already been busy replacing things without any change, annoyingly! I do feel that the BMS PBX aggravates these problems, but not cause them if that makes sense.

The biggest issue that I am having at the moment that I am trying to solve is the pinging or knocking between 1800 and 2500 rpm, mostly at moderate throttle inputs, but have noticed it on gear changes when driving a bit more spiritedly. So very annoying! And also have that dull performance drop off from 3000 - 4500 rpm before the power comes back like crazy! Hesitation has been there from day one and very irritating, and certainly not something that I would have expected from a BMW!

Today I tested something out (did something that I have indirectly trained myself not to do), I mashed the throttle while in 4th at around 60 - 80 km/h and get that sudden hesitation. Try it again soon after and it's fine, but let the car settle and maybe try 5th gear and again, mash the throttle and there's that somewhat violent hesitation.

Engine also feels lumpy to me - off throttle and there is an overrun jerk, then gently feed power back on and there is a slight jerk, so not the refinement that I want at all. Bought some Liqui Moly injector cleaner which I am going to try out and see, but I somehow doubt that this is going to help, and I am really now getting to the end of my patience with this car!
07 328 e90
It's the characteristic of the car.....
At least that's what I've been told from the dealer.
I have the powerbox in as well and it does amplify the effects, I have to keep it on stock map for now so it's not as bad, but still is.
I have changed out the plugs, coils, MAF, air filter, had the fuel pump checked, fuel sending unit checked, fuel injectors checked, and then some, I had been leaning towards the gas pedal position sensor, maybe something to do with the stability control sensors, or just a bad throttle body.
I'm tired of dumping money and time into this car. If it weren't for my commute, I would go back to Dodge trucks.
At first I suspected a bad powerbox, it happens, but BMS responded back to me with such a shitty response saying to get a 335. Then asked if I installed it right. Hello, I'm not an idiot! Perhaps they are with their instructions, a couple of pin numbers to connect the wires to said it was one color but it wasn't the color in the car as they said it was. I connected it to the pin number. I then questioned myself if that was right, so it has to be something else, it's just a damn mystery.