View Single Post
      09-27-2012, 06:59 AM   #1
Bimmer84
Guardian of the Night
Bimmer84's Avatar
United_States
28
Rep
1,826
Posts

 
Drives: 2010 335i M Sport Coupe
Join Date: Oct 2010
Location: San Antonio

iTrader: (5)

Garage List
2010 335i E92  [3.75]
Is My iDrive Screen Dead?

So I was driving today and noticed on two different occasions that when I would get in and start the car, I couldn't press down on the gas pedal at all, like it was stuck. Once I pressed start, it would release just fine, and had no issues with driving.

Anyway, my iDrive screen was fine on my seperate driving occasions, expect just a few minutes ago when I left the store, and started my car the screen turned completely orange. It wouldn't do anything else, it just stayed orange, and after about a minute, it would go black. Everything seems to work normal otherwise. Voice commands work, radio, CD, onboard music and all that. I tried using the voice commands to turn the display off and on again, but it just went back to orange and then would shut off.

I just hit 20k on my odometer this week.

I have included a picture, and I wrote the first part just for some strange reason it could be related.
Attached Images
 
__________________
2010 335i M Sport Coupe -- Black Sapphire Metallic|Coral Red|Loaded|JB4 Stage 3|BMS DCI|VRSF DPs|Camaross 6k AE|Performance Gloss Black Grilles|CF Performance Spoiler|CF Quad Diffuser|Double Layer Black Chrome Quad Tips|CF Roundels|Smoked Reflectors|Red Cyba Scoops|193s Painted Lamborghini Metallic Dark Gray