View Single Post
      09-30-2012, 04:37 PM   #5
Lotus 7
Registered
0
Rep
1
Posts

 
Drives: 2006 325xi
Join Date: Oct 2010
Location: Vermont

iTrader: (0)

Problem with IBS

My 2006 328xi wagon would not start several days ago. The steering wheel would not unlock nor could I get the car out of gear. The car would not crank either. I tried a jumper box but it would not start the car. I put a charger on the car overnight and still nothing.

The next day I got out my small code reader and the problems seemed to be with the IBS. I got to the battery and found the IBS and disconnected it (blue connecter). Once it was disconnected the car started fine. There was water in the battery box which I pumped out. I let everything dry out but when I plug the IBS back in the car will not start and I have the same symtoms once again. Not sure exactly what the IBS does other then disable a car that would otherwise run just fine. The fact that it disables the car rather then just throwing a code is very annoying. If I did not find this tread I would have had to have the car flat bedded to a dealer and it would have to be dragged onto the flatbed as I could not put the car in N.

So far the car has not thrown any codes with the IBS disconnected. Does anyone know if it will be a problem if I leave it in the present state? Has anyone replaced and IBS before? I can see it on the top of battery negative terminal. It does not look hard to replace. If anyone has any thoughts on how I might get my present IBS back working that would be great. Of course I also need to find the leak into the battery box. It seems to be coming from rear quarter window. If anyone knows what this might be I would be grateful.

Thanks!

Gary