View Single Post
      10-03-2012, 04:30 PM   #1
SDW335
Second Lieutenant
 
SDW335's Avatar
 
Drives: BMW Drei-Reihen
Join Date: Dec 2007
Location: Sarasota, Florida

Posts: 258
iTrader: (2)

Burning Smell after Transmission Service

Took my car in for a transmission service (filter, gasket drain and fill), and now I have a smell (smells like burning BO), after I start the car as the AC gets going.

I noticed it yesterday after I stopped at the grocery store on the way home from the service. The car shifts perfect and don't notice any negative feedback while driving.

I can smell it slightly when I garage the car, but it's mainly noticible after it sits after some "spitited" or distance driving.

I called the independent shop and the owner says there may have been some fluid that dripped on the exhaust that will burn off, but I drove through a lot of rain today and it's not any better. He advised me that I should give it a few days to be sure and not to worry unless I "discover fluid on my garage floor"

I'm not so sure I trust that advise and wanted to see if anyone else has gone through a similar issue? I know there have been horror stories about services gone bad and I don't want to risk hurting the transmission.

Note: Indy Shop reassured me that they made sure by looking at the tranny in addition to the VIN before adding fluid to make sure they used the right one. This is a shop that ONLY works on BMW and Mercedes, which is why I chose them in the first place.

Cheers!
SDW335 is offline  
0
Reply With Quote