Thread: Need help
View Single Post
      10-12-2012, 03:15 AM   #1
Aznfe
Private First Class
1
Rep
110
Posts

 
Drives: 07 e92 328xi
Join Date: Apr 2012
Location: Seattle

iTrader: (0)

Need help

I just bought a jb4 with g5 board from taye90 but the software is outdated and i want to update it before installing. Problem is it didnt come w the bms usb cable nor i have a windows laptop. Does anybody here that lives in the greater seattle area can help me update my jb4? I can buy you a lunch or something. Thanks in advance