View Single Post
      10-18-2012, 07:43 AM   #1
mike5809
BMW CCA #459447
 
mike5809's Avatar
 
Drives: '11 335i M-Sport [LeMans Blue]
Join Date: May 2011
Location: York, PA

Posts: 490
iTrader: (5)

Garage List
Exclamation CBS Light: Front & Rear Pads + Handbrake Light - normal at 45k?

Hi All,

*added pictures - I just find it weird that the "BRAKE" light, Rear Brake Service, and Front Brake Service lights all come on at the same time.

I check my CSB/Service indicator at least twice a week - and at the beginning of the week, it said I had 7,000 miles on front brakes and I believe 10,000 miles on rear brakes.

* Also just last week, I had the car at the dealership for a brake fluid flush/change as well - which at that time, they reset the CSB for brake fluid.

Well this morning my Service Light (Car on Lift) went off. So I checked the CSB and it says that both front and rear brakes need serviced (both came on at the exact same time). ALSO my Handbrake light is now constantly illuminated while the car is on, even though the handbrake is not engaged.

With that, I have a few questions;
- Is it normal for both Front and Rear Brake Service Indicators to go off, even though the mileage for both were different?
- Is it normal for the Handbrake indicator to be active as well?
- If not, would you think it is a faulty relay or something?
- The vehicle has 47k, based on that mileage do rotors usually need replacing or just pads

- If this is normal, what is the average cost at a BMW dealership to replace;
- Front & Rear Pads
- Front & Rear Pads and Rotors


*My car is scheduled to go in the shop Tuesday for Wastegate replacement (for the second time), so they are going to look at the brakes then - but I am hoping to gather some information so that I can be informed before then.

Thanks so much!
Attached Images
     
__________________

'11 BMW 335i M-Sport Coupe xDrive [LeMans Blue] - Starke 19in Wheels, Exotics Tuning CF Lip, CF BMW Performance Diffuser, M3 Spoiler, Eibach Springs/Bilstein Shocks, 35% Tint
'07 BMW 335i Coupe - Sold
'03 BMW Z4 3.0i - Gone

Last edited by mike5809; 10-18-2012 at 01:27 PM.
mike5809 is offline   United_States
0
Reply With Quote