View Single Post
      10-20-2012, 01:51 PM   #1
psmitty95
Brigadier General
 
psmitty95's Avatar
 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT

Posts: 3,566
iTrader: (8)

Water Pump on its way out? (Weird Noise)

So basically earlier this week i've been hearing this weird high pitched noise when the car isn't in boost. It happens mainly if the car is idling and I hold the revs between 1-1.2k or if i'm driving and coasting slowly while in gear. I brought it to the shop today and we put it on the lift and it sounds like the water pump but I wanted to see if anyone else has had this noise and can confirm its the water pump or something else. I just want to be sure before I order a new pump and have it installed... Here's some pictures of where we think the noise is coming from and also a video i took earlier this week. The noise has gotten slightly better than it was in the video but its still there. I have my fuel gauge set to show the water temp and i've been monitoring that but otherwise the car seems to behave normally. Pulls hard as it usually does, builds boost normal, etc...

Edit: Also forgot to mention on the way home from the shop (45 minute drive on the highway) I was watching the temps and they didn't really go above the 1/4 tank mark which I think is 210 degrees.

Also should mention the noise happens while the car is turning off but once the engine stops the noise is gone it doesn't continue to run afterwards.





__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: FBO + Meth JB4 ISO, BB flash, VRSF DP/FMIC, ER CP, Stett, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno

Last edited by psmitty95; 10-20-2012 at 02:02 PM.
psmitty95 is offline   United_States
0
Reply With Quote