View Single Post
      11-14-2012, 10:27 PM   #36
Tony@vargasturbotech
BimmerPost Supporting Vendor
Tony@vargasturbotech's Avatar
49
Rep
1,221
Posts


 
Drives: N54
Join Date: Aug 2012
Location: USA

iTrader: (0)

Quote:
Originally Posted by atomos319 View Post
What I don't get is how my turbos sound like that with less than 3k on them. I got new turbos under warranty for wastegate issues. I have spent the past month trouble shooting, trying to make absolutely sure the car didn't have some other problem. I just got my DME flashed back to stock, and I will drive it stock through thanksgiving and then I plan to take it in and ask WTF?? I'm thinking they were bad parts from the get-go OR there was an install error.( I actually went back the day after because the car seemed to oscilate- not accelerate smoothly as I left the dealer- they said it was fine) I was afraid that after going back to stock they would quiet down some and then the dealer would tell me nothing is wrong. Happily, the car is now 100% OEM and still sound the same. Combine the sound with boost issues and random limp modes i've been getting....we'll see if the third time is a charm

I will keep the car stock until spring so that if this next set is messed up- I won't have to go through this ordeal AGAIN.
Install error could cause it, ie, not getting the intake tubes on right and getting something sucked in there. Don't get me wrong I have seen turbos go a LONG time when howling, and I have seen some fail quickly after the noise began. Its not a reason to panic, just know turbos are not supposed to sound like that. Once you start seeing the smoke you know its time to get them swapped. How long that will take is impossible to tell.

Last edited by Tony@vargasturbotech; 11-14-2012 at 10:34 PM.