View Single Post
      11-15-2012, 03:54 PM   #9
alcolite
First Lieutenant
 
Drives: '02 e46 Vert
Join Date: Nov 2011
Location: Brampton

Posts: 320
iTrader: (0)

Hey guys, thanks for all the replies, also thanks to OC as well for helping me out the entire time. He is a great seller, and has been there every step of the way. I however hadn't seen pictures of them on the car, not their condition, just as OC had mentioned he IS a very trusted member for which reason, my morals gave me no choice but to trust him completely-- which I still do, of course. However, when "installed", I only plugged the lights into the connectors to turn them on, however I hadn't positioned them inside the light at this point when I noticed two of the LED's out, so in terms of installation difficulties, the bulbs weren't placed inside the bulb for it to have been damaged. Being myself an avid member of this forum, I searched and viewed various videos before installing them, before even getting the Lux.

I wouldn't have minded paying customs as I understand what UPS does, but wasn't expecting as much as USPS doesn't f*** importers as much, lol. Even with the import fees I was happy, however with the item not working I'm not sure whether its fair for me to also bear the entire fees and end up with less than half what I paid after returning the item. Not saying that I'm right or wrong, but again fairness is the biggest concern here.

Any and all suggestions are welcome to help through this problem, but for some reason I don't feel that me burdening all the costs should be fair, just as it wouldn't be fair for the seller to lose money.
alcolite is offline  
0
Reply With Quote