View Single Post
      11-21-2012, 06:58 PM   #6
kgroschi
Lieutenant
 
kgroschi's Avatar
 
Drives: 08 M5 [GONE], now '09 E90 335i
Join Date: Feb 2012
Location: California, USA (Born in Munich, Germany)

Posts: 434
iTrader: (0)

Same Problem

Quote:
Originally Posted by Wolf 335 View Post
Driving today on the highway with cruise control and the check engine light pops up. I continued to drive and turn off cruise control because i had to slow down. However when i tried to accelerate again the car started to shake as if i was driving over rumble strips on the road. Tried again and it shook again quite violently.

Immediatelly i get into thh right lane to pull over and see what happening and then the check engine light goes away and no issues accelerating.

Now everything is fine.

Anyone with similar experience?
OMG I JUST WANTED TO POST THAT. I had similar issues starting last week and I feel like it's coming up more often. I am on COBB Aggressive and thought it might have something to do with Misfiring or that I lost a Turbo or something. But as stated here, after driving with the vibration and engine light on for a few minutes, the light turns off and the shaking stops and I regain full power.

I brought the car to my independent shop today, and he said he can't find anything. No codes, nothing that leaks or looks wrong and also on the test drive he couldn't get to that problem (maybe cause I de-installed the COBB).

Any ideas?
kgroschi is offline   Germany
0
Reply With Quote