View Single Post
      11-28-2012, 03:17 PM   #18
psmitty95
Brigadier General
 
psmitty95's Avatar
 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT

Posts: 3,445
iTrader: (7)

Quote:
Originally Posted by Lankster View Post
Definitely understand your predicament, just the other night I experienced that, and 8 minutes into driving softly and all my friends crackin up because they thought I was full of it my blinkers go off signaling my engine has reached optimal heat and wham!

Definitely like what you have done with your car. Something I aspire to get done in my copious spare time... hows the TC holdin up?
Yea it takes mine anywhere form 8-10 minutes depending on how cold it is. I gotta turn on the JB4 blinkers when warm whenever I get a chance cause I have them off now and I always have to keep an eye on the oil gauge.

Thanks, hopefully gonna order a few more cosmetic mods today. As far as performance I think I might be done other than adding an exhaust although that doesn't really count. So far TC and clutch are holding up perfectly. I don't do any hard launches and rarely do moderate launches. I am the second owner and I think the car may have a aftermarket clutch although idk... It was one of the stiffest clutch's i've ever driven and it sometimes engages very harsh. I'm also surprised its not slipping considering the car has 52k miles and the power it's probably making... I'm hoping to hop on a dyno sometime soon in the next few weeknds.
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: FBO + Meth JB4 ISO, BB flash, VRSF DP/FMIC, ER CP, Stett, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
psmitty95 is offline   United_States
0
Reply With Quote