View Single Post
      12-02-2012, 01:38 PM   #1
asus389
Lieutenant
asus389's Avatar
United_States
10
Rep
491
Posts

 
Drives: 06 E90 325i
Join Date: Jun 2009
Location: Michigan

iTrader: (0)

Garage List
2006 BMW 325i  [0.00]
Braking shimmy again! Problem with ATE rotors?

I took my e90 325i in for service a year ago and my brakes were getting low. At the time I had 60k on my OE BMW brakes with about 3-4mm to go on each pad. On top of that, I was getting a shimmy in the steering wheel on braking lightly at high speeds. The shop installed new brakes. They told me they were ATE Premium One rotors and Jurid pads.

The shimmy seemed to go away, but then it came back a few months later. Thrust arm bushings were then replaced (they looked worn and fluid was leaking), but this didn't solve the problem. They told me there was a hot spot on the right front rotor and then they resurfaced them and the shimmy went away. It only took a couple months to come back.

I don't track my car and I have never "warped" rotors on any of my other cars and I drive this car pretty much the same as I always have. It seems odd that this would happen 3 times within 10k miles/1 year across 2 sets of pads/rotors. What could be going on here? Is there something else wrong with my car that could be causing it to do this? Other parts of the braking/suspension/steering system that could screw up my brake rotors? Anyone else have experience with this rotor/pad combo?

Last edited by asus389; 12-02-2012 at 02:20 PM.