View Single Post
      12-30-2012, 12:58 AM   #2
robc1976
DIYER
 
robc1976's Avatar
 
Drives: E90 335i
Join Date: Mar 2012
Location: Illinois

Posts: 4,223
iTrader: (11)

Quote:
Originally Posted by spoolin View Post
I had my turbos replaced under warranty less than a year ago. I am no longer under warranty and have recently started noticing smoke and an oil smell when I come to a stop. This happens on rare occasions and does not necessarily happen when I am getting into boost as I have thought that may provoke it but it does not. I know it may be the turbo seals but are there any other possibilities? It never does it until it at least 120 degrees. When it does it it can let out alot of smoke but it only does it for a few seconds and then stops. I am xxxless but can differ between fuel and oil smell. I am just looking for any experience or ideas that anyone may have.
is the smoke coming out of one side of the exhaust, is smoke coming out by the left side (passenger side) of the motor? Color of smoke? Does it go away when accelerating.
__________________
JB4 G5, WEDGE flash, 455 LPFP, HFS-4 meth kit, BMS OCC, RB turbos W/3.5 N20 sensor, RB valve, BMS DCI, 3" AR Dps, Custom OC W/ SS lines, ER FMIC, ER CP W/HKS BOV, M3 control arms, M3 guide rods, M3 upper links, M3 front & rear sway-bars, Meyle HD tie-rods, HPA rear toe arms, Wavetrac LSD, DEFIV kit, KW clubsport coilovers, Power-Flex subframe bushings, stoptech rotors, Rogue Tranny Mounts, 1M bumper, M3 CF hood, MORR VS8.2 rims 245/295
robc1976 is offline  
0
Reply With Quote