View Single Post
      12-31-2012, 08:41 PM   #4
ctuna
Brigadier General
 
Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

Posts: 4,089
iTrader: (0)

I advise you to use a Technic Harness.

I advise you to use a Technic Harness.
If you do that you won't have to cut or splice any wires, at least for the
amp. It comes with a connector that fits right into the OEM wire harness .
If you notice there is a lever on the connector going into the amp
you just throw it and everything disconnects.
You can see picture of it in one of the first photos .
(amp with technic harness white connector)
I believe he can also supply the factory connectors
for the speaker or at least give you the part numbers.
Also he now sells speaker ring adapters and I say some other ones for sale on one of these postings today that are metal.
Molex connectors are a pretty standard connector you can
pick up at most electronic stores. They are mail and female crimp pins
that go into a plastic housing.
As far as the wiring goes I have been told 150 watt is
the limit from Technic I believe. So unless you are bridging the underseats it won't be a problem. Actually some that have bridged have burned out the speakers
I don't know if they were Jehnerts but I wouldn't want to risk burning those . My Jehnerts have been running for a year with one channel each from and xd 600/6 with no
problems.
If your using your DQXI I hope it takes balanced diff outputs from the radio.

Last edited by ctuna; 12-31-2012 at 09:07 PM.
ctuna is offline  
0
Reply With Quote