View Single Post
      08-27-2007, 01:01 PM   #8
M3-FAST
Defected to the dark side.....
M3-FAST's Avatar
England
84
Rep
5,791
Posts

 
Drives: BMW M5 LCi
Join Date: May 2007
Location: Stafford, UK

iTrader: (11)

Garage List
Quote:
Originally Posted by keithIOW View Post
My fuel pump has just gone again.

I think that I'm going to reject the car.

I've had the car for five months and it's been in and out of the dealership constantly in thet time. So far I've had 2 fuel pump failures, the roofs packed up, and there's some strange noises coming from under the bonnet.
What signs (if any) did you have of the fuel pump failing again - when mine failed the car felt hesitant beforehand - I was sure something wasnt right - I have had the pump replaced (supposedly!!) but the car still feels a bit jittery at times - often does not want to accelerate away smoothly - more noticeable when accelerating very gently, maybe in a line of traffic increasing from 20-40mph gradually. Hard to describe but feels like its holding back?

Also noticed last week that the top 5 lines of the heated screen do not work (only the bottom 2/3 of the screen clears) - this does not look an easy 'screen to swap!!

Today my lad noticed that 'his' rear speaker was not working - checked his theory out by using the balance/fader and directing it to rear n/s speaker - sure enough it was dead. An hour later when I got home the speaker was workin again!!

I am also getting fed up of visiting my dealer. They had it for 4 weeks to fix the steering rack. A week to replace the fuel pump. In again to sort a badly aligned wing and had to return to collect the missing ipod lead and have new mat fixings (sticky pads had fell off!)

Let me know how things go - I had an Audi before and it was trouble free motoring and good dealer support. I feel BMW could learn some lessons from them!!

Paul