View Single Post
      01-14-2013, 06:44 PM   #25
E9TOU
First Lieutenant
 
Drives: 2010 E92 335i
Join Date: Apr 2008
Location: Goleta, CA

Posts: 311
iTrader: (0)

Garage List
Send a message via AIM to E9TOU
Quote:
Originally Posted by jjaguilar07 View Post
ok, so the other day i got the dreaded SES light along with the sputtering and loss of power. Weird thing it lasted for about 10 seconds then light went off and car went back to normal. Oh, before i forget i have a 2010 335i with M-sport and Performance package as well. I have exactly 50,003 miles on the car right now. After reading this im kinda freaking out thinking it could be all of these issues or who knows what else. To make matters worse just had to replace both rear tires along with a rim due to crack. They said they checked everything before it left the dealership now this happens. Makes me think they saw somthing and said "oh well, warranty is up soon let him pay for it". Anyways, im getting off track here. So i havent had another SES light or loss of power(yet). I did notice after this happened my car is now going through a tank a little quicker than normal(about 60 miles less per tank). I was wondering what could cause this and what i should expect when i take this bad boy in. Any recommendations would be awesome. thank you in advance!!
It's probably your injectors, spark plugs or coils, or any combination of those. If you've gotten the SES light, it'll likely get worse and you'll have to bring the car in for service. You will start noticing that the engine vibrates a lot more violently and the smell of gasoline. You should bring it in to get it looked at. This happened to me and it lasted about a month before my car became un-drivable.
E9TOU is offline   United_States
0
Reply With Quote