View Single Post
      02-06-2013, 08:20 PM   #2
joec500
Brigadier General
45

 
Drives: it has 4 wheels
Join Date: Jul 2008
Location: San Francisco


Posts: 3,004
iTrader: (10)

UPDATE: So I think I solved many of my throttle issues that I have been having for the past 1-2 years.

Symptoms:

1.) car has very sluggish throttle response (no CEL) almos felt like a limp mode, but once you re-cycle the car, it drives fine.
2.) Stuttering on occasion during WOT (not traction control kicking in)
3.) The above slowly occuring more frequently.
4.) 2cf6 codes throwing the car into limp mode, yes you can rest adaptations etc, but that might buy you a few hundred miles.

My conclusion: the electronics/motor in the throttle body slowly degrade over time until it gets to the point where you are in limp mode all the time with the 2cf6 code more and more frequently.

Replaced my Throttle body (pretty easy), took me an hour or so, but could probably do it a lot quicker the next time. The part is about $330 from my local dealer or $315 from tischer.

After replacement, the throttle feels so much smoother and I cannot replicate the stuttering at WOT.

My car is an 11/06 build with the Siemens Throttle body, the replacement is made by continental.

Hopefully this is helpful to others.
__________________
2007 E92 6MT SGM: MusicarNW Level 2, Procede Rev 2.5, FFTEC/Vishnu LPFP with Flexfuel Sensor and Flash, M3 Offset V701's, WaveTrac LSD, Michelin PSS, Downpipes, M3 Control Arms, TCKline D/A Suspension, LCI Tail lights, Lux AE's, ER Charge Pipe, DCI's, Mtech Front and Rear, M3 Sideskirts, HPF Stage 1 Clutch