View Single Post
      02-12-2013, 02:55 AM   #1
MikeR1994
Second Lieutenant
United_States
5
Rep
227
Posts

 
Drives: 06 e90 325i, 05 325Ci (RIP)
Join Date: Sep 2011
Location: Charlotte, NC

iTrader: (0)

Garage List
2006 BMW 325i  [0.00]
Low coolant light when coolant is not low...

So I have a low coolant light right now that started after I installed catless headers. I have a CEL right now but it's for misfires and just needs to be cleared since I have now fixed that problem, so those two aren't related. Could I have damaged the coolant level sensor in the expansion tank when I was shifting it around to get to the exhaust manifolds? I thought I was being pretty careful with it but you never know. On a side note after finally hunting down a couple exhaust leaks, having to take the headers off and replace the gaskets, and fixing my misfire problem, I noticed that my passenger side engine mount is blown. I swear the problems keep adding up on this car. I'll be off to college next year so I can't exactly afford to pay someone to do the work, but at least it has been a great learning experience and it makes me feel like a very accomplished owner, haha. Let me know what you guys think. Thanks
-Michael
__________________
-Michael
Active Autowerke Stage II | MMW CSv2 Exhaust | MMW Catless Headers | BC Racing BR Extreme Low Coilovers | custom adjustable rear suspension links | 19" Hyperblack CSL's | M3 style front | trim wrapped in brushed steel vinyl | Slightly smoked tail lights with clear reverse lights | factory xenons