View Single Post
      03-06-2013, 07:58 PM   #104
SneakyDeeky
Lieutenant Colonel
SneakyDeeky's Avatar
United_States
42
Rep
1,596
Posts

 
Drives: '07 E90 335i 6MT
Join Date: Feb 2011
Location: Redondo Beach, CA

iTrader: (5)

Garage List
2007 BMW 335i E90  [4.68]
2014 Audi SQ5  [5.00]
Quote:
Originally Posted by Mike@N54Tuning.com View Post
I've never heard of this type of a failure before. Both the pump and solenoid would need to get stuck on to allow meth to spray off-boost and they run on independent circuits on the FSB unless it's one of the really old ones. Might be worth OP sending the FSB in to have that tested to determine if it failed and why.
I'd be more than happy to send the FSB in for testing, especially if it could help others avoid a similar outcome.

Quote:
Originally Posted by enrita View Post
yeah seems very unlikely to me as well....
If I had to bet money on what caused the failure, I would not have guessed this. In fact, I'd have guessed the opposite as I thought it was far more likely that the lack of methanol and the octane it provides was what caused the issue. Honestly, I don't know what to think at this point.

All I know is that my savings towards a dedicated track car just took a $10K hit (not sure on exact cost yet as labor is still adding up). Plus, since I'm swapping engines I'm having some other work done too like cleaning the carbon build-up, installing a new thermostat and water pump, new SPEC Stage 2+ clutch, and a Quaife LSD. Once it's running again, I'll probably swap the JB4 for a Cobb... all of which uses up my track car savings.
__________________

6MT | FBO | Spec2+ | ER Dual Oil Coolers | 3.46 Wavetrac | StopTech | KW V1 | GC Camber | M3 Bits | Advan RS | LS3 AEs | Dyno Results | Pics