View Single Post
      08-03-2013, 06:32 AM   #98
Built My Way
Lieutenant
 
Built My Way's Avatar
 
Drives: mls ----------
Join Date: Apr 2011
Location: The Surly Maritimes ;)

Posts: 416
iTrader: (0)

Garage List
Quote:
Originally Posted by BroncoHound View Post
Has anyone else had a problem with broken wires to the connector for the thermostat? I went to replace my water pump and thermostat today and found this:


Has anyone replaced this wiring harness? It includes the water pump connection, a ground, and runs up beneath the valve cover. I can't seem to find it on Ticher's fiche's and it was 4:30pm today when I found it so, of course, my local dealership parts department was already closed. Can anyone give me some guidance on where to look for a new harness?
You could try calling/emailing Bavarian Autosport (New Hampshire) Free shipping to 48 states over $150.00. Or... is there any way you can get close enough to solder the wire back together then coat with plastidip wire insulation? All the best.

Added: What you could do is severe the entire thermostat part of the harness maybe a couple of inches above the connector, take it indoors under better access and lighting conditions and try soldering a piece of repair wire to the connector. Then solder the cut harness leads back together. The only thing now is to be careful that you have enough slack in the harness to connect to the thermostat. Just a thought.
__________________
Jesus saves and Espo scores on the rebound.

Last edited by Built My Way; 08-03-2013 at 06:48 AM.
Built My Way is offline   Canada
0
Reply With Quote