View Single Post
      04-13-2009, 02:05 PM   #1
prich2004
Private First Class
prich2004's Avatar
2
Rep
124
Posts

 
Drives: E90 335i
Join Date: Jun 2008
Location: Houston

iTrader: (0)

Garage List
2008 E90 335i  [0.00]
Exclamation Unexplained Limp Mode with Rev. II

Everything was amazing until...
I was in an accident (ran over a curb head on) and had to have a bunch of work done to my car including suspension, new power steering pump, new belts, new control arm, etc. Work was done on the car with mods installed. The car handles great now, like brand new. But it looks like I have ran into a problem...

As soon as I picked up my car after the repairs from the shop, I started testing out the performance. Whenever I go WOT, I always induce "limp mode". I took it back to the shop (same day) and they told me that the code I was getting was low fuel pressure so they gave me a new fuel pump.

The next day, I go WOT again. Same thing...limp mode. I went to another shop today and we decided are going to revert to stock tomorrow and see if we have the same problems.

Given the above info, does anyone have any idea what else it could be? I'm still getting the low fuel pressure code (scanned it today). Could some valves/hoses be loose? What do you think? If I can avoid additional serious work on my car, that would be great, but I want to see what others think it could be before I go to the shop tomorrow afternoon.

Thanks!
__________________
E90 335i | Metallic Graphite | AT Step | Sport | Premium | Satellite | iPod | Ceramic Tint | PROcede V4 | BMS DCI