View Single Post
      06-26-2009, 04:24 PM   #33
Mike@N54Tuning.com
BimmerPost Supporting Vendor

 
Drives: 07335i
Join Date: Dec 2008
Location: Earth

Posts: 13,905
iTrader: (83)

Quote:
Originally Posted by R12ax7 View Post
On the way home from work yesterday I got the dreaded "Engine Malfunction: Reduced Power" message. Has anyone else gotten this with their only mod being JB+, not altered from the factory middle setting?

Is it almost certain that since it induced this limp mode I have a code thrown?

The circumstances: It was very hot and humid here when I was driving home, I had the A/C on "Max" for parts of my drive (only about a 20 min drive) and the engine malfunction message appeared in the last 5 minutes or so, after some WOT driving and possibly not fully warmed up yet. I got the message while I was about to pull off the highway and honestly, the "Reduced Poer" didnt feel nearly as reduced as I would have expected. When I got off at my exit and there was a red light I turned the car off and on again. No long cranks although the idle seemed/seems a little rough (then again this seems to be true of bone stock n54s).

Any thoughts? My main concern is that I threw a code.
Sounds like a VANOS code to me, since it did not turn on while you were under heavy boost. Adding more power puts a more strain on the VANOS system and sometimes brings out problems that were already there more easily. Since you had the JB+ at the default setting no need to worry about detection codes. Just remove and take it to the dealer, or if you want to self diagnose get a BT scan.

Mike
__________________
BEST PRICES GUARANTEED - New N54 Performance Line Downpipes!!
JB4 **G5** On Sale - FREE Shipping Click Me - NEW JB4(N55) & DCI's $95.00
NEW F30 N20/N55 ER Downpipes and Chargepipes - BMS OCC (On Sale)
Mike@N54Tuning.com is offline   Canada
0
Reply With Quote