View Single Post
      09-19-2009, 03:29 PM   #5
StoneCold
Captain
8
Rep
614
Posts

 
Drives: BMW 2008 328i Coupe, Pro 02/08
Join Date: Mar 2008
Location: Vancouver, WA

iTrader: (1)

Quote:
Originally Posted by jmd_forest View Post
Yes, yes yes....in retrospect, springing for the $750 radiator only available from the dealer would have been smarter than the $125 used unit that I didn't know didn't include the sensor until it arrived in the mail. Live and learn.

The only additional variable is the transplanted sensor into the radiator so, go ahead take a shot.

Does any of the data provided in the recorded events indicate a problem? Engine temp of 101 C seems a bit high, but it seems reasonable if is were coming from the transplanted rad sensor it would be LOWER that actual not higher due to brazed fit of the original sensor. Unfortunatley, since these cars do not have a temp gauge, its a bit hard to monitor the temp while driving.

I'm leaning toward either the new thermostat is not operating correctly or the transplanted sensor. I'd just like enough confidence that if I replaced wither of these costly items, it will actually solve the problem.

If anyone know of a way to test the thermostat, please chime in. IIRC it is one of the new electrically operated units, not a standard wax expansion unit.

Thank you for the responses. I appreciate the help.

jmd_forest

Temp sensor failed. This one attached to the radiator and you MUST replace the radiator along with the sensor to solve this issues. You are right there Op. Go for it & GL.