View Single Post
      12-20-2010, 08:10 PM   #13
blacksail337
Private First Class
 
blacksail337's Avatar
 
Drives: 07 335xi
Join Date: Aug 2009
Location: fredericksburg, va

Posts: 190
iTrader: (0)

i've actually yet to get it resolved! this is still the same ongoing issue i currently have another thread going about that orangedawg has been providing me some info on.

i thought i looked the transfer case servo motor up on getbmwparts for $650, searching under my actual model not a 5 series, but thats been awhile so it may not still be accurate.

i'm leaning more towards the ABS/stability control module being the problem, which is listed on tischers for $1800 . . . . even better news!

or as orangedawg brought to my attention, a wheel speed sensor, which will also make everything go crazy, which are $450 a peice . . . . . . . . . .

but orangedawg recommended a company that actually rebuilds the control modules in my other thread for around $300, so that would def be worth looking into if your able to confirm that is in fact the problem.

i wouldn't be the least bit surprised if something as trivial as that battery cable was the problem though as ridiculously overcomplicated and temperamental as these cars are. it's funny you mention that too because i was checking mine one day and comparing the wires to the diagram in the bentley manual and it seemed something was wrong or out of place with mine too, and there was evidence that the moron that owned my car before me had some subwoofers/amps/garbage in the car previously, so that'd be great if it's something that simple that he broke or removed. that is unless that cable is just as insanely overpriced as everything else for this car!

and just to clarify the symptoms i was describing when i started this thread actually went away after about a month, the abs and brake light went off, and my awd was restored and the grinding noise on startup went away. the car drives normal i just can't disable the stability control using the button on the dash and it seems overly sensitive/confused in slick conditions

this is my first bmw and i've had a pretty horrible experience with this car overall which kills me because it's absolutely amazing to drive, hands down my favorite car of the 8 i've owned but i'm def done with the brand after this, just too high maintenance and expensive to repair
blacksail337 is offline  
0
Reply With Quote