View Single Post
      02-22-2011, 09:56 PM   #38
jzchen
Captain
United_States
6

 
Drives: 335xi Sedan
Join Date: Sep 2008
Location: Arcadia, CA


Posts: 633
iTrader: (0)

Quote:
Originally Posted by orangedawg View Post
Okay, so I tried calibrating steering sensor. BT enthusiast (the cheap, 3 VIN version) does have this function as you noted above. Did it per your instructions, but it didn't fix problem. I think it's that servo motor. Dang! I was hoping this would work. My error comes up as soon as you start the, without moving it or putting it in gear, moving steering wheel, etc.

BTW, when I scanned errors using BT tool, I did not have a steering wheel sensor error, but I still have that transfer case error - clutch position unknown error. Cleared all errors, started car, and scanned again and transfer case error still comes up (as well as the Christmas tree set of lights on dash).

Well, it was worth a try. Car runs and drives fine, albeit in 2wd and no ABC, no DSC, etc. Just have to see if I want to replace transfer case to get rid of errors.
Don't worry. After they changed my ECU from MSD80 to MSD81, I found I can not code in my professional BT tool! (I was interested to see what they programmed my speed limiter to be, and I think the setting is in the coding section. After contacting them it doesn't sound like I'll be able to code anytime soon either!) Did you cycle from ignition on to ignition off back to ignition on after clicking "Yes"?

This is really strange, because these errors all came up with me even though I didn't touch the bottom of the car, and they all went away after the steering angle sensor adjustment... I had reset the clock and date, renitialized the sunroof, made sure the one touch operation of the windows worked,... I hope you didn't fry the transfer case running in 2WD mode, (kind of like you were towing the car incorrectly as a bad analogy.)

Last edited by jzchen; 02-22-2011 at 11:16 PM. Reason: Poor spelling