View Single Post
      03-30-2011, 11:30 PM   #1
AWD Addict
Chief Executive
AWD Addict's Avatar
36
Rep
2,483
Posts

 
Drives: 2008 335xi 6spd Coupe
Join Date: Dec 2007
Location: Boston

iTrader: (1)

Garage List
2008 335xi  [0.00]
Rough Idle, stumbling rpms

At idle on a warm engine, no fan or A/C, I'm getting a rough idle. A kind of irregular stutter that i can feel in my seat and on the shifter. Even my brother in the passenger seat feels it.

I've had it for a long time, and just thought it was part of hte HPFP issue, but I've had 3 replaced, and I'm currently on the "fixed" one, and i still have it.

At roughly 20k miles, the car went through a 1wk diagnostic with a ton of tests and eventually they took off the valve cover, and the whole valve train was "gummed up" I was supposed to get pictures but never did. They cleaned them out, and the car ran smoother and faster than it had since it was new, and the rough idle went away...


...for a while.

Since then, now approaching 40k miles (and the end of my warranty - when I want this fixed by!) - the stutter is back and as bad as ever. It came on slowly, and gradually. I figured my HPFP was on the outs again, so i took it in again and they said to replace it with the newest version. I've been questioning these last few visits how this problem could be the fuel pump if it's not doing anything after so many tries, but my SA said this was it. No dice. Car still randomly shakes or jerks, or kind of stumbles at a redlight. Needle just keeps hunting for rpms. 800, 650, 400 (jerk) 700.

The car starts with a kind of stumble into idle too (clumsy start), and it stalled about a month ago on me (fully warmed up.)

MY rpms move up and down, irregularly and intermittently sometimes stable with the jerks, sometimes up and down 200-300 rpms.

I'm thinking they should take the valve covers off again, but my SA tells me if they do it, and find nothing, I'm on the hook for a 7hr job.

Thoughts?

Last edited by AWD Addict; 04-01-2011 at 02:26 PM.