View Single Post
      04-18-2011, 02:16 PM   #20
Monster900
Zeed
 
Monster900's Avatar
 
Drives: BMW 335i Coupe
Join Date: Nov 2009
Location: Detroit, MI

Posts: 391
iTrader: (0)

Quote:
Originally Posted by timmahh View Post
- Sorry this is such a long post; just want to make sure it was detailed! -

The night I bought my car I got on the freeway and realized the driver headlight was lighting up the sky, I manually adjusted it down but it would shake on every bump and during initial startup it wouldn't adjust up/down [self check]. Left to right movement is fine on turns, but again, no height adjustment.

Car went to the dealer on Wednesday for a few things including the headlight, when I picked it up they said everything was fine. I explained the situation but they assured me they saw no fault codes, so it was operating as it should. I explained again that it isn't leveling itself, however adaptive movement is fine, and the tech told me they don't do that - only left to right movement.

I said fine and took the car back, I know people on here mentioned some arm/bracket connected to the lower control arm that attached to the headlight.. FYI there isn't one.

There is a small arm on the left and right front suspension that connects to a servo/data input kinda box.. this is what sends the info to the headlight servo, there's no physical connection to the headlight. There should also be two in the back that monitor load weight to adjust headlights so they aren't blinding anyone.

I decided to try and figure out what the hell was wrong with my light, I didn't want the dealer to spend hours looking at things and say they couldn't find anything.

So here's what I found:

1) The adjustment screws are independent of the Left-Right and Up-Down movement. Use those to aim properly, it shouldn't affect the automatic movement.

2) I took the bumper off and then took the headlight out, there are two servos in the headlight that control movement. The servo attached to the Up-Down movement was popped out of place.

This explains why it wouldn't level, and why the dealer says everything was fine -- because as far as the electronics go it's all fine.. That's also what irritates me, I explained to the tech if something was physically disconnected but the electronics were fine, the computer wouldn't know.. but again, they just assured me it was working as intended.


Hopefully this helps anyone who may be having an issue!

Picture 1: You can see the ball is close but not in the socket


Picture 2: This is end that should be in the socket


Picture 3: This is the socket side of the headlight



To fix it I unplugged the servo motor, it comes out just like a bulb, small turn counter clock wise to remove it. I adjusted the height manually until it was at the end of the screw [visible from inside], figured that might move it further out a little and help with getting it popped back in.

To pop the ball back in you'll want to kinda put the servo in at an angle so the ball end is sitting on the top of socket, then use a flathead to pop it back into the socket all the way. Push the servo back in the rest of way, tighten and reconnect all wires, then fire the lights up to make sure it works. If so, put your baby back together and you're all set!

Just to let you all know you can fix this issue without taking front bumper off and take headlight assy out. Just take front portion of wheel wall cover off, take off xenon bulb assy cover in the back off headlight assy and move whole xenon bulb assy bracket up or down depending if your light is pointing up or down. Put xenon bulb and wheel wall cover back on and you are done. It shouldn’t take more then an hour.
Monster900 is offline   Canada
0
Reply With Quote