View Single Post
      11-22-2005, 03:42 PM   #1
BitStream
First Lieutenant
 
Drives: 2006 330i
Join Date: Nov 2005
Location: New Jersey, US

Posts: 344
iTrader: (1)

Garage List
2006 330i  [0.00]
Send a message via AIM to BitStream
Angry 06 330I - 2k Miles - Leaking PS Fluid - BAD RACK?!

I took delivery of my Graphite 06 330I about 3 weeks ago.

Couple of days after, I noticed that there was a significant whining noise coming from the motor which seemed to get worse as I was turning the wheel.

I immediately looked in the book for anything power steering related - I couldn't even find the power steering fluid reservoir listed in the book!

I went to the dealership, picked up a can of power steering fluid and topped her off. This seemed to solve the problem. About a week later, same exact thing. I topped it off and made an appointment with the dealer.

Fast forward to today - dropped the car off this morning. Just got off of the phone with the dealer who tells me the rack needs to be replaced - all of the seals have failed and the rack is leaking!!! :mad:

Also of note, when I took delivery of the car the steering wheel was pointed slightly left when driving straight. This point is kind of mute now anyway since they will need to re align the car once the new rack is installed.

Anyone have any experiences like this?

I was informed the rack is on order for tomorrow, and I should be able to pickup the car tomorrow night.

I'll keep you posted ...
BitStream is offline   United_States
0
Reply With Quote