View Single Post
      07-01-2011, 07:17 PM   #1
magamaga
-
 
magamaga's Avatar
 
Drives: BMW 325i
Join Date: May 2005
Location: Houston, Texas

Posts: 526
iTrader: (0)

Garage List
2006 325i  [0.00]
Exclamation I-drive does not turn on....Help!

So,
A week ago, I was driving and the i-drive reset. So I let it reset. Then a few minutes later it did it again and 5 mins later it did it again.
It finally did not come on and it's been a week that it has stayed powered off even though I have stopped and started the car many times. I can hear the CD\DVD's spinning and everything in the car works with the exception of the i-drive, so therefore I can't hear anything and the knob controller doesn't have any response like it used to before.
I was thinking that maybe my screen had gone bad but because the know has no resistance , I know for a fact that the i-drive is not on.
The car is not reporting any alerts.

So I just went in and check ALL the fuses in the fuse box and they are ALL fine. None blown.

I just passed the 50,000 miles and the car is no longer under new car warranty. I only have the extended maintenance warranty.

Has this happened to anybody? If so please help me.

Thanks!

__________________
325i Sparkling Graphite/Navigation/Steptronic/HeatedSeats/ DRL Angel Eyes/Metal Pedals/Tail Pipe Tips/Rear BMW Spoiler/BMWAlarm/LoJack/BlackLineTailLights/Hardwired BeltronicsProfessionalRX65RadarDetector/Rear FogLights/Debadged/LUX 5.0/ACS Roof Spoiler
magamaga is offline  
0
Reply With Quote