E90Post
 


GT Haus
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > ConnectedDrive / I-Drive / Navigation Related Discussion > I-Drive froze on Nav Screen



Reply
 
Thread Tools Search this Thread
      05-24-2007, 07:38 AM   #1
tmj69
New Member
tmj69's Avatar
0
Rep
18
Posts

 
Drives: 2007 E90 335i
Join Date: Apr 2006
Location: Huntersville, NC

iTrader: (0)

Garage List
2007 E90 335i  [0.00]
I-Drive froze on Nav Screen

Yesterday I experienced my first glitch with i-drive. I was leaving work last night and my nav screen was stuck on the map. I was unable to move the controller to the left and access any of the icons. I was also unable to move the controller up to get back to the nav options. However, I was able to move the controller to the right and access the split screen. I also could use the info button and get into each menu from the start screen. After the car sat for a few hours I got in and drove home and everything was fine. Today everything seemed fine as well. I searched and didn't see any info on this particular problem. Any ideas? Thanks guys.
__________________
E90 335i Arctic/Terra 6M, ZSP, ZPP, Nav, ZCW, Sirius, CA, Rear Shades, PCD 3/6
Appreciate 0
      05-24-2007, 08:36 AM   #2
poiney
Captain
15
Rep
798
Posts

 
Drives: 328i coupe
Join Date: Dec 2006
Location: SJ

iTrader: (0)

I've had a similar problem with Navi freezing sporadically. It typically stayed frozen when I stopped the engine and restarted immediately. But if I let it sit for a few minutes, it seemed to reset. Sounds like your problem.

I had additional issue that my sat radio went dead for minutes at a time, rarely. I had it serviced, they claimed they found a loose wire that might have been culprit but since problem is so rare who knows if it is fixed. Time will tell.
Appreciate 0
      05-24-2007, 08:49 AM   #3
Josh49
Major General
95
Rep
6,665
Posts

 
Drives: E90 325xi
Join Date: Jan 2006
Location: Boston, MA

iTrader: (33)

ctrl alt delete = two ejects and power.. that should reset it for you..
__________________

E90 325XI, MYSTIC BLUE ON BLACK/ALUM, STEP, NAV, PDC, CWP, XENON, SIRIUS, ALARM, MUD GUARDS, CLEARBRA, CHROME GRILLS AND TIPS, VALENTINE 1 (HARDWIRED), HO CERAMIC 40%, 161'S, REAR FOG MOD, LUX 4.0, BLACKLINES, OEM PEDALS, MTEC FOGS, GRUPPE-M REP INTAKE. 156'S AND RUBBER MATS FOR THE WINTER.
Appreciate 0
      05-24-2007, 12:42 PM   #4
SoYank
Major General
SoYank's Avatar
United_States
88
Rep
7,504
Posts

 
Drives: 2009 E90 335i MT
Join Date: Mar 2006
Location: Brighton, Colorado

iTrader: (1)

Garage List
Send a message via Yahoo to SoYank Send a message via Skype™ to SoYank
My whole iDrive occasionally fails to boot. I've been taking close notes of when this happens and I thought it happened when it was raining. Then that got shot down when iDrive failed to boot on a sunny day. It now seems to be if I start it up, drive a mile or so, shut the engine off and restart it in between 3 and five minutes. What I do is then turn the engine off and wait twenty. Upon restart, iDrive comes on as normal.

What I see when iDrive hickups is the screen will go a light gray at first for about two seconds and then blank. It will then blink about every half minute and the LED on the SOS button will blink at the same time. I had the entire system replaced because it failed hard but now it's just intermittent and an annoyance.
__________________
2009 E90 335i Montego Blue Black Leather Burl Walnut 6MT US Spec
SatNav ZPP ZCW 6FL TPMS iDrive PDC HWS Xenons BMW Assist Power Rear Sunshade Logic 7
European Taillights Rear Foglamp OEM Alarm PicoTray DataToys XM-DVR Multi-view Processor
Quaife ATB LSD Short Shift Knob Hartge Anti-Roll Bars AP Racing Front Brakes 19" Style 269
Appreciate 0
      05-25-2007, 08:15 AM   #5
tmj69
New Member
tmj69's Avatar
0
Rep
18
Posts

 
Drives: 2007 E90 335i
Join Date: Apr 2006
Location: Huntersville, NC

iTrader: (0)

Garage List
2007 E90 335i  [0.00]
Thanks for the replies and advice. So far (knocking on wood as I type) this has only happened that one time. I will remember the ctl alt del technique for future use. Thanks again.
__________________
E90 335i Arctic/Terra 6M, ZSP, ZPP, Nav, ZCW, Sirius, CA, Rear Shades, PCD 3/6
Appreciate 0
      05-25-2007, 12:12 PM   #6
SoYank
Major General
SoYank's Avatar
United_States
88
Rep
7,504
Posts

 
Drives: 2009 E90 335i MT
Join Date: Mar 2006
Location: Brighton, Colorado

iTrader: (1)

Garage List
Send a message via Yahoo to SoYank Send a message via Skype™ to SoYank
Quote:
Originally Posted by tmj69 View Post
Thanks for the replies and advice. So far (knocking on wood as I type) this has only happened that one time. I will remember the ctl alt del technique for future use. Thanks again.
I've tried the BMW three-finger salute on several occasions to no avail.
__________________
2009 E90 335i Montego Blue Black Leather Burl Walnut 6MT US Spec
SatNav ZPP ZCW 6FL TPMS iDrive PDC HWS Xenons BMW Assist Power Rear Sunshade Logic 7
European Taillights Rear Foglamp OEM Alarm PicoTray DataToys XM-DVR Multi-view Processor
Quaife ATB LSD Short Shift Knob Hartge Anti-Roll Bars AP Racing Front Brakes 19" Style 269
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:09 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST