E90Post
 


Evolve Automotive
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > E90 Auto M/S Upshift Problems



Reply
 
Thread Tools Search this Thread
      07-17-2011, 11:18 PM   #1
F1330
New Member
 
F1330's Avatar
 
Drives: BMW 330XI
Join Date: Mar 2011
Location: Montreal

Posts: 25
iTrader: (0)

E90 Auto M/S Upshift Problems

Hi,

I haven't been able to find any posts on this issue. Tonight I took my car (2006- 330XI) out and I like driving on the m/s mode sometimes. The car shifter was able to work in "D, DS, and would shift to 1st on m/s mode" however when I wanted to upshift in m/s mode it would not let me.

Does anyone have the wiring diagrams for me to verify which wire might be off behind the shifter. The car is out of warrently and I know I'll be pinned with a large bill.

Thanks for your help.
F1330 is offline  
0
Reply With Quote
      07-17-2011, 11:21 PM   #2
Timothy J
Captain
 
Timothy J's Avatar
 
Drives: 08 335xi
Join Date: Sep 2010
Location: West Point, NY

Posts: 732
iTrader: (1)

Garage List
2008 BMW 335xi  [0.00]
Never had this issue with my 6MT..
__________________
2001 Chevy 2500HD Duramax
2008 BMW 335xi Coupe 6MT | Jet Black | Loaded Sold
Timothy J is offline   United_States
0
Reply With Quote
      07-18-2011, 07:22 PM   #3
F1330
New Member
 
F1330's Avatar
 
Drives: BMW 330XI
Join Date: Mar 2011
Location: Montreal

Posts: 25
iTrader: (0)

SHifting Issues

I checked the wiring underneath the booth and everything is intact. Has anyone ever had an issue in which their M/S did not work?

I'm new at these threads , don't know if I'm addressing the issue properly.
F1330 is offline  
0
Reply With Quote
      07-18-2011, 07:57 PM   #4
X2Board
Late Apex
 
X2Board's Avatar
 
Drives: '11 X5 M
Join Date: Feb 2011
Location: Wake County, NC

Posts: 739
iTrader: (1)

Quote:
Originally Posted by Timothy J View Post
Never had this issue with my 6MT..
X2Board is offline   United_States
0
Reply With Quote
      07-18-2011, 08:23 PM   #5
fdriller9
Banned
 
Drives: '06 AW 330xi
Join Date: Mar 2009
Location: North Jersey/Philly/NYC

Posts: 7,090
iTrader: (4)

Garage List
2006 330xi  [3.22]
The micro switch is most likely broken. You'll need a new assembly. I just had mine replaced because it was throwing transmission errors on my car. Though it worked fine. It just sometimes told me on start up that P, R, N, or D may not be selected.

My car lied though. I was always able to shift into R, N, and D....

Some have been able to find used ones on eBay for cheap. Like the $70 range.
fdriller9 is offline   United_States
0
Reply With Quote
      07-18-2011, 08:32 PM   #6
F1330
New Member
 
F1330's Avatar
 
Drives: BMW 330XI
Join Date: Mar 2011
Location: Montreal

Posts: 25
iTrader: (0)

Thanks, that is the closest I got from getting an answer. Does the piece have a specific name or is it simply called a micor switch? Thanks.
F1330 is offline  
0
Reply With Quote
      07-18-2011, 08:37 PM   #7
fdriller9
Banned
 
Drives: '06 AW 330xi
Join Date: Mar 2009
Location: North Jersey/Philly/NYC

Posts: 7,090
iTrader: (4)

Garage List
2006 330xi  [3.22]
Quote:
Originally Posted by F1330 View Post
Thanks, that is the closest I got from getting an answer. Does the piece have a specific name or is it simply called a micor switch? Thanks.
Give me a minute to get my receipt....I beleive it's the shifter assembly.
fdriller9 is offline   United_States
0
Reply With Quote
      07-18-2011, 08:44 PM   #8
fdriller9
Banned
 
Drives: '06 AW 330xi
Join Date: Mar 2009
Location: North Jersey/Philly/NYC

Posts: 7,090
iTrader: (4)

Garage List
2006 330xi  [3.22]
The white boxed out area is just my vin....the receipt lists the part #, as well as the diag code and fault code....you'll need INPA to pull those. I didn't see them with my Bav Tool. There are no prices because it was done under CPO. You can check getbmwparts.com for prices.

[IMG]http://i714.photobucket.com/albums/ww146/*********/DSC01726.jpg[/IMG]
fdriller9 is offline   United_States
0
Reply With Quote
      07-18-2011, 08:50 PM   #9
F1330
New Member
 
F1330's Avatar
 
Drives: BMW 330XI
Join Date: Mar 2011
Location: Montreal

Posts: 25
iTrader: (0)

Thank you very much, I'll look into it.
F1330 is offline  
0
Reply With Quote
      07-18-2011, 09:03 PM   #10
F1330
New Member
 
F1330's Avatar
 
Drives: BMW 330XI
Join Date: Mar 2011
Location: Montreal

Posts: 25
iTrader: (0)

Found your piece, they replaced the whole shifter as it was in guarantee and probably didn't want to take the chance. In my case it is out of warranty I imagine as I had 4 years or 80,000 km.
In my case I have no warning light just the fact that when I try to upshift on manual mode the system doesn't allow it. I thought I'd fix it myself but get the feeling that I'll be going to BMW shortly. thanks for the help.
F1330 is offline  
0
Reply With Quote
      07-18-2011, 09:09 PM   #11
fdriller9
Banned
 
Drives: '06 AW 330xi
Join Date: Mar 2009
Location: North Jersey/Philly/NYC

Posts: 7,090
iTrader: (4)

Garage List
2006 330xi  [3.22]
Quote:
Originally Posted by F1330 View Post
Found your piece, they replaced the whole shifter as it was in guarantee and probably didn't want to take the chance. In my case it is out of warranty I imagine as I had 4 years or 80,000 km.
In my case I have no warning light just the fact that when I try to upshift on manual mode the system doesn't allow it. I thought I'd fix it myself but get the feeling that I'll be going to BMW shortly. thanks for the help.
Yea no problem.....check eBay. I've heard of a few people having this problem. Some couldn't shift into DS at all. Some could shift into DS but not M/S mode.

Either way good luck.
fdriller9 is offline   United_States
0
Reply With Quote
      07-18-2011, 11:54 PM   #12
atown88
Major
 
atown88's Avatar
 
Drives: e90
Join Date: Apr 2010
Location: Seattle

Posts: 1,442
iTrader: (0)

You must have been a happy cusotmer after that service. lol
atown88 is offline   United_States
0
Reply With Quote
      07-19-2011, 03:14 PM   #13
F1330
New Member
 
F1330's Avatar
 
Drives: BMW 330XI
Join Date: Mar 2011
Location: Montreal

Posts: 25
iTrader: (0)

Looks like you can't have the micro-switch on its own, you need to buy the whole assembly on the E90. Checked a couple of sources on the net and they all said the same thing when it came to the E90 chasis.
F1330 is offline  
0
Reply With Quote
      09-10-2011, 07:42 PM   #14
Me_Hi
Major
 
Me_Hi's Avatar
 
Drives: *
Join Date: Jun 2009
Location: *

Posts: 1,491
iTrader: (13)

2$ switch and you get to replace the whole part. No wonder why so called mechanics these days fix things by replacing Lego pieces. No effort to actually fix on the cheap ...
__________________
Me_Hi is offline   No_Country
0
Reply With Quote
      09-13-2011, 07:47 PM   #15
First VR4
Enlisted Member
 
Drives: 2006 330xi
Join Date: Oct 2008
Location: Pine Bush, NY

Posts: 38
iTrader: (0)

Hmm. my 06 330xi just started doing the same thing today. Will not shift over into DS or MS mode!!!!!!! I bump the gear selector over but it does not even register on the display.
I don't get a warning light of any sort though????

Last edited by First VR4; 09-13-2011 at 07:53 PM.
First VR4 is offline  
0
Reply With Quote
      10-01-2011, 10:00 PM   #16
F1330
New Member
 
F1330's Avatar
 
Drives: BMW 330XI
Join Date: Mar 2011
Location: Montreal

Posts: 25
iTrader: (0)

Hi, I ended up finding the problem through this thread

http://www.e90post.com/forums/showth...hlight=upshift


Believe it or not if you are able to follow the instructions on the thread, chances are you'll find the problem. I couldn't believe it, it works up to now

My other issue tonight is that I changed my brakes last summer with a new sensor and the car lighted up tonight telling me I'm at -300 with the breaks and need to service. There's always something. Good luck.
F1330 is offline  
0
Reply With Quote
Reply

Bookmarks

Tags
m/s, shifter, upshift

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:10 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST