E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > BRAKE light still on after pad/sensor replacement



Reply
 
Thread Tools Search this Thread
      07-26-2011, 02:35 PM   #1
07GraphiteXI
Private First Class
 
Drives: 07 328XI
Join Date: Dec 2010
Location: MA

Posts: 107
iTrader: (1)

Unhappy BRAKE light still on after pad/sensor replacement

Hey All,

I changed my front brake pads and pad sensor last weekend. I reset the lights through the CBS reset button method (car accessories on, odo reset, etc) but the BRAKE light and car on lift signs still come on.

When I reset through CBS, it showed as -9,000 miles on the indicator.

I think it's one of the following things:
  1. I didn't fully seat the sensor properly
  2. My rotors were kinda worn (ridge around the edge) so maybe this has something to do with the light being on?
  3. The place where the sensor sits is dirty (this shouldnt matter though since it's circuit based)
  4. I bought a faulty sensor
  5. Is it possible to mess up the polarity when installing the sensor? Maybe I did this?

Let me know if I'm missing something.

Thanks!
__________________
2007 SGM/Black 328xi|6MT|Sport|Premium|Xenon
07GraphiteXI is offline  
0
Reply With Quote
      07-26-2011, 08:10 PM   #2
kevin@bavarianx
Banned
 
Drives: E36 M3
Join Date: Jul 2010
Location: Brea, CA

Posts: 812
iTrader: (3)

Send a message via AIM to kevin@bavarianx
I would try the CBS reset button again. Did you hold the BC button and wait for the clock to finish?
kevin@bavarianx is offline   United_States
0
Reply With Quote
      07-26-2011, 09:19 PM   #3
JunkStory
Major
 
Drives: naked.
Join Date: May 2008
Location: 98230

Posts: 1,172
iTrader: (3)

Quote:
Originally Posted by sales@bavarianx View Post
I would try the CBS reset button again. Did you hold the BC button and wait for the clock to finish?
That's what I was thinking, since it still says -9000 miles on the indicator.

By the way, extremely curious here - How much of the brake pad was left after being 9000 miles overdue?
JunkStory is offline  
0
Reply With Quote
      07-26-2011, 09:34 PM   #4
07GraphiteXI
Private First Class
 
Drives: 07 328XI
Join Date: Dec 2010
Location: MA

Posts: 107
iTrader: (1)

Quote:
Originally Posted by JunkStory View Post
That's what I was thinking, since it still says -9000 miles on the indicator.

By the way, extremely curious here - How much of the brake pad was left after being 9000 miles overdue?
It was -700 before i reset. Then when I reset it, it went to -9000.

I tried it a couple times and yes, I did wait for the clock to finish. Still stumped here....
__________________
2007 SGM/Black 328xi|6MT|Sport|Premium|Xenon
07GraphiteXI is offline  
0
Reply With Quote
      07-27-2011, 08:13 PM   #5
07GraphiteXI
Private First Class
 
Drives: 07 328XI
Join Date: Dec 2010
Location: MA

Posts: 107
iTrader: (1)

bump
__________________
2007 SGM/Black 328xi|6MT|Sport|Premium|Xenon
07GraphiteXI is offline  
0
Reply With Quote
      07-31-2011, 12:28 PM   #6
07GraphiteXI
Private First Class
 
Drives: 07 328XI
Join Date: Dec 2010
Location: MA

Posts: 107
iTrader: (1)

sunday bump...
__________________
2007 SGM/Black 328xi|6MT|Sport|Premium|Xenon
07GraphiteXI is offline  
0
Reply With Quote
      08-09-2011, 09:53 AM   #7
pgh330xi
Registered
 
Drives: 2006 330xi
Join Date: Aug 2011
Location: Pittsburgh

Posts: 4
iTrader: (0)

Did you ever find a solution to your problem with the reset? I'm have the same issue. I had all the brakes replaced by Firestone and i had to reset the indicators myself. The front one reset and the rear wont. I tried adjusting and cleaning the rear sensor to no avail.
pgh330xi is offline   United_States
0
Reply With Quote
      08-09-2011, 10:42 AM   #8
blue335xi
Captain
 
blue335xi's Avatar
 
Drives: 2008 335i
Join Date: Feb 2011
Location: Saint Louis,MO

Posts: 622
iTrader: (26)

when I replaced brakes on my e46 m3 I had to do this to reset it.
push emergency brake down with the button pushed in for about 15 sec.
blue335xi is online now   United_States
0
Reply With Quote
      08-09-2011, 10:50 AM   #9
07GraphiteXI
Private First Class
 
Drives: 07 328XI
Join Date: Dec 2010
Location: MA

Posts: 107
iTrader: (1)

Quote:
Originally Posted by pgh330xi View Post
Did you ever find a solution to your problem with the reset? I'm have the same issue. I had all the brakes replaced by Firestone and i had to reset the indicators myself. The front one reset and the rear wont. I tried adjusting and cleaning the rear sensor to no avail.
No I didn't. I'm planning on opening it up again soon. Did you get new sensors or just replace the old ones?
__________________
2007 SGM/Black 328xi|6MT|Sport|Premium|Xenon
07GraphiteXI is offline  
0
Reply With Quote
      08-09-2011, 11:50 AM   #10
pgh330xi
Registered
 
Drives: 2006 330xi
Join Date: Aug 2011
Location: Pittsburgh

Posts: 4
iTrader: (0)

Firestone claimed to have replaced the sensors but i guess i can't be sure. Do they just unplug somewhere? I suppose i can try a new rear sensor.
pgh330xi is offline   United_States
0
Reply With Quote
      08-28-2011, 04:12 PM   #11
jbimmer3
Captain
 
jbimmer3's Avatar
 
Drives: E90
Join Date: Aug 2007
Location: Layton, UT

Posts: 876
iTrader: (3)

Same problem with the rear.....
__________________

Car pics HERE
jbimmer3 is offline   United_States
0
Reply With Quote
      08-28-2011, 10:43 PM   #12
vasillalov
Mad Linux Guru On The Loose
 
vasillalov's Avatar
 
Drives: 2008 335i Sedan
Join Date: Aug 2009
Location: Chicago, IL

Posts: 4,132
iTrader: (3)

Garage List
2008 335i E90  [4.00]
Why not use the BT tool to update the service interval on your brake pads?

Also, the brake light could come on because your brake fluid needs to be changed every 2 years. There is a timer for that as well..
__________________
Equal Opportunity Harasser!
6MT | COBB | AR | AE | Forge DV | HPF | P3 Gauge | Hybrid Intake | O.S.Giken TCD | All M3 bits | TCKLine
vasillalov is offline   Bulgaria
0
Reply With Quote
      08-29-2011, 10:41 AM   #13
benzo23
Colonel
 
benzo23's Avatar
 
Drives: 14 F30 AW MSport
Join Date: Apr 2010
Location: FL

Posts: 2,884
iTrader: (1)

Bump, was this ever resolved because im going to be doing rotors, pads, fluid & sensors on wednesday...
benzo23 is offline  
0
Reply With Quote
      08-29-2011, 02:03 PM   #14
BobS
Lieutenant Colonel
 
BobS's Avatar
 
Drives: M3
Join Date: Feb 2009
Location: Jersey City, NJ

Posts: 1,531
iTrader: (0)

I had my brakes, pad, rotors, sensors, etc. replaced and the shop I used reset the intervals with the Idrive yet the light was still on. They couldn't figure out how to get the light off so I drove home, plugged in my BT tool and reset the interval with the BT tool. The light went off.

I think you guys need to reset it with the BT scan tool.
__________________

Evolve Supercharged E92 M3
BobS is online now  
0
Reply With Quote
      08-30-2011, 09:26 AM   #15
vasillalov
Mad Linux Guru On The Loose
 
vasillalov's Avatar
 
Drives: 2008 335i Sedan
Join Date: Aug 2009
Location: Chicago, IL

Posts: 4,132
iTrader: (3)

Garage List
2008 335i E90  [4.00]
Quote:
Originally Posted by BobS View Post
I think you guys need to reset it with the BT scan tool.
Correct! That is the proper procedure.
__________________
Equal Opportunity Harasser!
6MT | COBB | AR | AE | Forge DV | HPF | P3 Gauge | Hybrid Intake | O.S.Giken TCD | All M3 bits | TCKLine
vasillalov is offline   Bulgaria
0
Reply With Quote
      08-30-2011, 10:27 AM   #16
fdriller9
Banned
 
Drives: '06 AW 330xi
Join Date: Mar 2009
Location: North Jersey/Philly/NYC

Posts: 7,090
iTrader: (4)

Garage List
2006 330xi  [3.22]
No you can reset it through the turn signal stalk. I did that on a friends E46 a couple weeks ago after changing his pads/rotors.

You guys probably aren't doing it right and/or the sensor is bad. Are you guys using OEM pad wear sensors?

Some aftermarket sensors are known to not work correctly.
fdriller9 is offline   United_States
0
Reply With Quote
      09-10-2011, 05:34 PM   #17
WWM3
Captain
 
WWM3's Avatar
 
Drives: 09 E90 M3 AW/FR
Join Date: Mar 2009
Location: PA

Posts: 603
iTrader: (7)

Where can you reset the brake pad interval in the BT tool. I click on conditioned based service and it does not pull up a reset option for brake pads/rotors - just brake fluid?
WWM3 is offline  
0
Reply With Quote
      10-26-2011, 12:38 PM   #18
Turkeybaster115
Banned
 
Drives: 335I
Join Date: Jun 2009
Location: Illinois

Posts: 1,544
iTrader: (2)

Quote:
Originally Posted by vasillalov View Post
Why not use the BT tool to update the service interval on your brake pads?

Also, the brake light could come on because your brake fluid needs to be changed every 2 years. There is a timer for that as well..
I just got back from the stealership, and just an FYI for you, and for everyone who read this thread. Once the vehicle shows the brake pad replacement light (which it will once you change the pads, and even if you replace the sensors), you cannot reset it, even with the BT tool. The new sensors need to get reprogrammed into the vehicle.

The stealership I went to tried to reset my car manually, then tried with their computer (Same as BT Tool), then realized that they need to do the reprogramming. I also replaced my oil level sensor, and that needed to be reprogrammed along with the brake sensors.
Turkeybaster115 is offline  
0
Reply With Quote
      10-26-2011, 01:54 PM   #19
mike3000fl
Eleven Bravo
 
mike3000fl's Avatar
 
Drives: 06 330i
Join Date: Feb 2010
Location: ft bragg

Posts: 2,149
iTrader: (0)

Quote:
Originally Posted by 07GraphiteXI View Post
It was -700 before i reset. Then when I reset it, it went to -9000.

I tried it a couple times and yes, I did wait for the clock to finish. Still stumped here....
There is actually a service bulletin put out by BMW for the E90 in 2008 (SIB 34 02 08) which corrects "Erroneous Brake Pad Replacement Messages" It is caused by an error in the DSC module and the CBS miscalculates.
__________________
2006 330i - Jet Black - 19" E46 M3 wheels - HR Sport - 188,000 Miles...

mike3000fl is offline  
0
Reply With Quote
      02-06-2013, 06:17 PM   #20
rjive
weekend > work
 
Drives: 2008 BMW 335i
Join Date: Jun 2011
Location: California

Posts: 62
iTrader: (0)

Quote:
Originally Posted by mike3000fl View Post
There is actually a service bulletin put out by BMW for the E90 in 2008 (SIB 34 02 08) which corrects "Erroneous Brake Pad Replacement Messages" It is caused by an error in the DSC module and the CBS miscalculates.
So with this TSB... does that mean you can't reset with stalk or BT scan?

Edit - I picked up my car from the indy shop and I was able to reset the light on the stalk. Not sure if this will help anyone.

Last edited by rjive; 02-07-2013 at 09:11 PM.
rjive is offline  
0
Reply With Quote
      05-23-2014, 01:15 PM   #21
knissel
Private
 
knissel's Avatar
 
Drives: 2008 335xi AT
Join Date: Jun 2012
Location: Cincinnati, OH

Posts: 93
iTrader: (0)

Garage List
2008 BMW 335xi  [0.00]
I'm having this issue and can't seem to solve it...
__________________
E85 Calculator for Mobile Android iPhone
08 335xi - JB4 G5 - BMS DCI - VRSF DPs - CXRacing FMIC, SteveAZ Inline Opt. 3, BMS e85 AT Flash - All Season Tires - 140k miles - 11.762 @ 118.40 (335xi Stock Turbo WR)
knissel is offline   United_States
0
Reply With Quote
      05-23-2014, 01:34 PM   #22
drilla2212
Private
 
Drives: e92 328i, z4, e46 m3
Join Date: May 2014
Location: dfw

Posts: 72
iTrader: (0)

You need to replace the sensors, if they ever get grounded they are done. I had to replace my sensors before I was able to reset the light even though mine weren't bad. Plus the sensors only run about $12 each and takes minutes to install
drilla2212 is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:06 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST