E90Post
 


European Auto Source
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Question about fuel pump.



Reply
 
Thread Tools Search this Thread
      06-06-2007, 04:53 AM   #1
chaodima
Enlisted Member
 
Drives: BMW 335I
Join Date: Mar 2007
Location: ROSEMEAD

Posts: 32
iTrader: (0)

Question about fuel pump.

if fuel pump broken, u car still can move?? or u must stop to call AAA.
chaodima is offline  
0
Reply With Quote
      06-06-2007, 07:08 PM   #2
robbie211
Captain
 
Drives: E90 335i, E36 M3
Join Date: Mar 2006
Location: OC

Posts: 811
iTrader: (16)

Garage List
2007 335i  [3.38]
When mine went out I was still able to drive although it was more of a limp home
robbie211 is offline   United_States
0
Reply With Quote
      06-13-2007, 03:24 PM   #3
cedchung
Second Lieutenant
 
Drives: 2006 E92 335i, 2014 F30 320i
Join Date: May 2005
Location: Montreal/Mauritius

Posts: 299
iTrader: (1)

The yellow half engine picture just lit on my way back home and it lost power. I restarted it and could drive normally. Is my fuel pump starting to fail?
__________________
cedchung is offline   Canada
0
Reply With Quote
      06-13-2007, 04:04 PM   #4
robbie211
Captain
 
Drives: E90 335i, E36 M3
Join Date: Mar 2006
Location: OC

Posts: 811
iTrader: (16)

Garage List
2007 335i  [3.38]
Quote:
Originally Posted by cedchung View Post
The yellow half engine picture just lit on my way back home and it lost power. I restarted it and could drive normally. Is my fuel pump starting to fail?
Sounds like your pump is about to fail. I had the yellow half engine light and check engine light. Restarted the car and no lights were on, started up fine. later in the day it had 2-3 sec crank delay before starting, then the message "engine malfunction - reduced power" came back as well as check engine. At that point I took it to the dealer and sure enough it was a bad fuel pump.
robbie211 is offline   United_States
0
Reply With Quote
      06-13-2007, 04:12 PM   #5
RiXst3r
 
RiXst3r's Avatar
 
Drives: www.p3cars.com
Join Date: Sep 2006
Location: Ohio

Posts: 6,459
iTrader: (14)

Send a message via AIM to RiXst3r
when mine failed... it was DEAD... car would stall after 20 seconds of rough idling
RiXst3r is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:08 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST