E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Fuel Filter prob fixed



Reply
 
Thread Tools Search this Thread
      06-14-2007, 04:43 PM   #1
dustman
Private
 
Drives: 11 M3 Comp Pkg
Join Date: Jan 2007
Location: So Cal

Posts: 95
iTrader: (0)

Fuel Filter prob fixed

car out of service for 21 days, am led to believe issue is fixed, new filter installed. If you are w/o one after 3 weeks, you should be calling BMW NA as I did...got the issue resolved in 2 days. Ridiculous to have this type of issue and drive a Hyundai and other Dodge garbage as I did for a while.
dustman is offline  
0
Reply With Quote
      06-14-2007, 05:26 PM   #2
RiXst3r
 
RiXst3r's Avatar
 
Drives: www.p3cars.com
Join Date: Sep 2006
Location: Ohio

Posts: 6,459
iTrader: (14)

Send a message via AIM to RiXst3r
care to give us some details as to what the problem was? I am guessing that your 335 had a bad fuel filter?? whats the deal with that? its a filter...
RiXst3r is offline  
0
Reply With Quote
      06-14-2007, 05:28 PM   #3
jon@themshop
Captain
 
jon@themshop's Avatar
 
Drives: BMW
Join Date: Apr 2007
Location: Los Angeles/Eagle Rock, CA

Posts: 759
iTrader: (8)

Quote:
Originally Posted by RiXst3r View Post
care to give us some details as to what the problem was? I am guessing that your 335 had a bad fuel filter?? whats the deal with that? its a filter...
The fuel pressure regulator and fuel filter are integrated together inside the fuel tank.
jon@themshop is offline   United_States
0
Reply With Quote
      06-14-2007, 06:44 PM   #4
dustman
Private
 
Drives: 11 M3 Comp Pkg
Join Date: Jan 2007
Location: So Cal

Posts: 95
iTrader: (0)

I gather from conversations there was a problem with the filter and the manufacturer couldnt/wouldnt supply, so BMW went with a new manufacturer but hasnt been able to ramp up. Tight supply still.
Case of squeeky wheel gets the grease, no pun intended.
dustman is offline  
0
Reply With Quote
      06-14-2007, 09:46 PM   #5
RiXst3r
 
RiXst3r's Avatar
 
Drives: www.p3cars.com
Join Date: Sep 2006
Location: Ohio

Posts: 6,459
iTrader: (14)

Send a message via AIM to RiXst3r
ok, this is not the High Pressure Fuel pump... my pump went out, and I was without my car for 7 weeks.... had nothing to do with the "filter"... I am trying to see if there is ANOTHER problem that might kill my car
RiXst3r is offline  
0
Reply With Quote
      06-15-2007, 10:55 AM   #6
dustman
Private
 
Drives: 11 M3 Comp Pkg
Join Date: Jan 2007
Location: So Cal

Posts: 95
iTrader: (0)

Car is done, fixed, tested with 100k miles post installation.
Dealer has been excellent in providing lease payment recoupment as well as an additional gesture of goodwill worth same value. Excellent. Paul has been one of the best service managers I've experienced.
After 3 weeks, I cant wait to drive a real car again!
dustman is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:12 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST