E90Post
 


Horizon LED
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > Echo on the phone?



Reply
 
Thread Tools Search this Thread
      11-09-2011, 02:00 PM   #1
Dvdman
Captain
Dvdman's Avatar
30
Rep
905
Posts

 
Drives: 2008 BMW 335 XI
Join Date: Aug 2009
Location: Chicago, IL

iTrader: (2)

Echo on the phone?

I tried searching but never found a solution. I have a Google phone and I plug it into my input in the consule to talk. I have great sound when talking on the phone but the people talking to me have an echo. I can't hear it. Anyone have a problem like this and find a solution?
Appreciate 0
      11-09-2011, 03:17 PM   #2
cole92
Second Lieutenant
cole92's Avatar
3
Rep
270
Posts

 
Drives: too much
Join Date: Sep 2011
Location: SoFlo / Tri-state / Mid-Atlantic

iTrader: (0)

Send a message via Skype™ to cole92
Will always have an echo due to no echo cancellation.

Also, should probably be in the audio section
Appreciate 0
      11-09-2011, 03:38 PM   #3
persianamir
First Lieutenant
3
Rep
354
Posts

 
Drives: 2006 330i
Join Date: Jul 2011
Location: Los Angeles, Ca

iTrader: (2)

yeah this happens no matter what...i find that lowering the in call volume through my phone or lowering ur sound helps a bit
Appreciate 0
      11-09-2011, 04:49 PM   #4
Dvdman
Captain
Dvdman's Avatar
30
Rep
905
Posts

 
Drives: 2008 BMW 335 XI
Join Date: Aug 2009
Location: Chicago, IL

iTrader: (2)

Thats blows. You think for a BMW they wouldn't have issues.
Appreciate 0
      11-09-2011, 04:54 PM   #5
fdriller9
Banned
United_States
102
Rep
7,090
Posts

 
Drives: '06 AW 330xi
Join Date: Mar 2009
Location: North Jersey/Philly/NYC

iTrader: (4)

Garage List
2006 330xi  [3.22]
Is this just a problem with Google phones? I don't ever get any echo in my car. I have an iPhone 3GS jailbroken iOS 4
Appreciate 0
      11-09-2011, 05:06 PM   #6
Dvdman
Captain
Dvdman's Avatar
30
Rep
905
Posts

 
Drives: 2008 BMW 335 XI
Join Date: Aug 2009
Location: Chicago, IL

iTrader: (2)

Quote:
Originally Posted by ********* View Post
Is this just a problem with Google phones? I don't ever get any echo in my car. I have an iPhone 3GS jailbroken iOS 4

Not sure..Ill try a different phone and see what happens.
Appreciate 0
      11-09-2011, 05:13 PM   #7
fdriller9
Banned
United_States
102
Rep
7,090
Posts

 
Drives: '06 AW 330xi
Join Date: Mar 2009
Location: North Jersey/Philly/NYC

iTrader: (4)

Garage List
2006 330xi  [3.22]
Quote:
Originally Posted by Devestator View Post
Not sure..Ill try a different phone and see what happens.
Wait are you talking about plugging your phone into the aux port or connecting it via bluetooth?

I'm talking about blueooth.
Appreciate 0
      11-09-2011, 05:22 PM   #8
Dvdman
Captain
Dvdman's Avatar
30
Rep
905
Posts

 
Drives: 2008 BMW 335 XI
Join Date: Aug 2009
Location: Chicago, IL

iTrader: (2)

I am talking about plugging in my phone to the aux port in the middle consule.
Appreciate 0
      11-09-2011, 07:21 PM   #9
Dark_Knight_335
Came to the N55 Darkside
Dark_Knight_335's Avatar
United_States
156
Rep
10,685
Posts

 
Drives: 2011 335 E93 M-Sport
Join Date: May 2010
Location: NY/NJ

iTrader: (27)

Same woes here- iPhone 4S with Bluetooth. 2009 E92 coupe. Then again, iPhone fails at Bluetooth so not sure where the fault lies really..
Appreciate 0
      11-12-2011, 04:17 PM   #10
cole92
Second Lieutenant
cole92's Avatar
3
Rep
270
Posts

 
Drives: too much
Join Date: Sep 2011
Location: SoFlo / Tri-state / Mid-Atlantic

iTrader: (0)

Send a message via Skype™ to cole92
Quote:
Originally Posted by Devestator View Post
Thats blows. You think for a BMW they wouldn't have issues.
Not a BMW issue, it's a phone issue. All phones will do that.
Appreciate 0
      11-12-2011, 04:17 PM   #11
cole92
Second Lieutenant
cole92's Avatar
3
Rep
270
Posts

 
Drives: too much
Join Date: Sep 2011
Location: SoFlo / Tri-state / Mid-Atlantic

iTrader: (0)

Send a message via Skype™ to cole92
Quote:
Originally Posted by SDeFranco1 View Post
Same woes here- iPhone 4S with Bluetooth. 2009 E92 coupe. Then again, iPhone fails at Bluetooth so not sure where the fault lies really..
I also drive an e92, 2009 and have 0 problems with 3g/3gs/4/4s.
Appreciate 0
      11-12-2011, 04:26 PM   #12
fdriller9
Banned
United_States
102
Rep
7,090
Posts

 
Drives: '06 AW 330xi
Join Date: Mar 2009
Location: North Jersey/Philly/NYC

iTrader: (4)

Garage List
2006 330xi  [3.22]
Yea it's because there is no echo cancellation as someone mentioned.

The only thing I can suggest is something like this:

http://www.amazon.com/Griffin-Techno...133187&sr=8-12

You can stream music and make/receive calls. It's very low profile too and will most likely fit in the armrest.

EDIT: So reading the description, the unit has a mic. So it will need to be in the open, such as the ashtray.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:17 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST