E90Post
 


Lux Angel Eyes
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > how common is an electric water pump failure for you FBO guys?



Reply
 
Thread Tools Search this Thread
      11-21-2011, 02:16 PM   #1
import36
Burrito bowl connoisseur
 
import36's Avatar
 
Drives: E92 335i MT, E46 M3 SMG
Join Date: Feb 2008
Location: Seven Cities

Posts: 3,428
iTrader: (1)

Garage List
2008 BMW 335i Coupe  [4.50]
2005 BMW M3  [5.00]
how common is an electric water pump failure for you FBO guys?

so thought i'd post this in here since i'm not sure how many of you read up in the Maintenance section. but about 2 months ago my car started overheating....ended up being the water pump. at that time, the water pump and thermostat were replaced, and i was back on the road. fast forward to today, and my car sits broke down in the garage......same overheating issue. i checked the codes and have all 3 water pump codes P2E83, P2E84, P2E85.

are any of you FBO'd guys experiencing issues like this? i know quite a few of you push your cars a lot harder than i ever have.....so i'm just curious if anyone else has ran into this issue. my car only has 18k miles on it in close to 4 years.

ps JP got me scared with all the electrical issues he was having.
__________________
Mods: Procede Rev3 9-10|AE Catless Dual Exhaust|AR Design Catless DPs|AMS FMIC|Stett Charge Pipe w/Tial BOV|Stett CAI|BMS OCC|BMS CDV|Volk TE37 SLs|KW V2 Coilovers|Cusco OS Strut Brace|Macht Schnell Stud Conversion|Work RS-R Lugnuts|Gloss Black Roof|Matte Black Kidney Grills|UED Lower Bumper Grills|OEM Aero Lip and Painted Reflectors|M3 Sideskirts| VRS Decklid Aero Spoiler|Gloss Black Roof|M Peformance Alcantara Steering Wheel(blue)|OSS V2.0 LED Angel Eyes|8000k HID Fog Lights|8000k MTEC Xenons
import36 is offline   United_States
0
Reply With Quote
      11-21-2011, 02:17 PM   #2
Jeff@TopGearSolutions
BimmerPost Supporting Vendor

 
Jeff@TopGearSolutions's Avatar
 
Drives: C6 Z06, GSXR-750, 09 335i
Join Date: Dec 2008
Location: TopGearSolutions.com

Posts: 16,685
iTrader: (31)

Send a message via AIM to Jeff@TopGearSolutions
BMW's alone are notorious for water pump failures.
Jeff@TopGearSolutions is offline   United_States
0
Reply With Quote
      11-21-2011, 02:25 PM   #3
bryce
Banned
 
Drives: zhp 3-pedal
Join Date: May 2010
Location: texas

Posts: 3,177
iTrader: (22)

Garage List
IMO something isn't right. i've owned 2 N54 vehicles now, i had the first one through 67k miles, my e90 now has 40k miles. no electric water pump issues on either car. two failures pretty close together on a low-mileage car is suspect of another issue at hand. i doubt being FBO/tuned makes a difference, either.
bryce is offline  
0
Reply With Quote
      11-21-2011, 02:30 PM   #4
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: 917-939-4980
Join Date: Jun 2007
Location: New York

Posts: 18,266
iTrader: (5)

Send a message via Yahoo to cn555ic
I have 9000 miles on my 07 which are hard driven miles. I had mine fail at 8000 miles and so far no issues but it's only 1000 miles later. These pumps are cheap to begin with. I hope it last longer than the 8000 miles on the original one. This is total BS
__________________

Coding E and F New York 917-939-4980
cn555ic is offline   United_States
0
Reply With Quote
      11-21-2011, 02:32 PM   #5
shyestsparks
Captain
 
Drives: 335i sedan, 02 Altima VQ35DE-T
Join Date: Feb 2007
Location: Ca

Posts: 827
iTrader: (5)

We had to replace mine at about 55k.
shyestsparks is offline  
0
Reply With Quote
      11-21-2011, 02:38 PM   #6
import36
Burrito bowl connoisseur
 
import36's Avatar
 
Drives: E92 335i MT, E46 M3 SMG
Join Date: Feb 2008
Location: Seven Cities

Posts: 3,428
iTrader: (1)

Garage List
2008 BMW 335i Coupe  [4.50]
2005 BMW M3  [5.00]
Quote:
Originally Posted by Jeff@topgearsolutions View Post
BMW's alone are notorious for water pump failures.
Quote:
Originally Posted by cn555ic View Post
I have 9000 miles on my 07 which are hard driven miles. I had mine fail at 8000 miles and so far no issues but it's only 1000 miles later. These pumps are cheap to begin with. I hope it last longer than the 8000 miles on the original one. This is total BS
that really sucks. thing is i had a track day planned for this past weekend too...guess it's a good thing the car broke down close to home than at the track. what boggles my mind is that i had less than 1000 miles on this new pump....what are the chances it was a faulty pump? probably slim....but who knows.
__________________
Mods: Procede Rev3 9-10|AE Catless Dual Exhaust|AR Design Catless DPs|AMS FMIC|Stett Charge Pipe w/Tial BOV|Stett CAI|BMS OCC|BMS CDV|Volk TE37 SLs|KW V2 Coilovers|Cusco OS Strut Brace|Macht Schnell Stud Conversion|Work RS-R Lugnuts|Gloss Black Roof|Matte Black Kidney Grills|UED Lower Bumper Grills|OEM Aero Lip and Painted Reflectors|M3 Sideskirts| VRS Decklid Aero Spoiler|Gloss Black Roof|M Peformance Alcantara Steering Wheel(blue)|OSS V2.0 LED Angel Eyes|8000k HID Fog Lights|8000k MTEC Xenons
import36 is offline   United_States
0
Reply With Quote
      11-21-2011, 02:52 PM   #7
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: 917-939-4980
Join Date: Jun 2007
Location: New York

Posts: 18,266
iTrader: (5)

Send a message via Yahoo to cn555ic
Quote:
Originally Posted by import36 View Post
that really sucks. thing is i had a track day planned for this past weekend too...guess it's a good thing the car broke down close to home than at the track. what boggles my mind is that i had less than 1000 miles on this new pump....what are the chances it was a faulty pump? probably slim....but who knows.

Damn 1000 miles and it happen again. That's is messed up. It's not a cheap part either. But having all three codes which is odd since when mine went it threw two codes weeks apart. First one was 2e81 and then 2e84. Total of 3 weeks after seeing these two codes the car overheated. Getting all three and then overheating so quickly after the codes is a concern
__________________

Coding E and F New York 917-939-4980
cn555ic is offline   United_States
0
Reply With Quote
      11-21-2011, 02:53 PM   #8
raceyBMW
king of the hills
 
raceyBMW's Avatar
 
Drives: 335i coupe
Join Date: Dec 2006
Location: Denver, CO

Posts: 2,735
iTrader: (1)

Garage List
1994 530i  [4.25]
2007 335i Coupe  [4.07]
Quote:
Originally Posted by Jeff@topgearsolutions View Post
BMW's alone are notorious for water pump failures.
The old ones yes, but I don't know if anyone can say that about the new electric water pumps. They don't seem to be too prevalent...yet.

Seems the 328's and 330's have them fail just as much as the 335's, so I don't think its a problem with being tuned. For the OP's case, very possible you just got a bad unit, or maybe another side issue that's causing it to work too hard and prematurely failing.
raceyBMW is offline   United_States
0
Reply With Quote
      11-21-2011, 02:55 PM   #9
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: 917-939-4980
Join Date: Jun 2007
Location: New York

Posts: 18,266
iTrader: (5)

Send a message via Yahoo to cn555ic
Quote:
Originally Posted by raceyBMW View Post
The old ones yes, but I don't know if anyone can say that about the new electric water pumps. They don't seem to be too prevalent...yet.

Seems the 328's and 330's have them fail just as much as the 335's, so I don't think its a problem with being tuned. For the OP's case, very possible you just got a bad unit, or maybe another side issue that's causing it to work too hard and prematurely failing.
The controller is the ecu.
__________________

Coding E and F New York 917-939-4980
cn555ic is offline   United_States
0
Reply With Quote
      11-21-2011, 03:12 PM   #10
Jeff@TopGearSolutions
BimmerPost Supporting Vendor

 
Jeff@TopGearSolutions's Avatar
 
Drives: C6 Z06, GSXR-750, 09 335i
Join Date: Dec 2008
Location: TopGearSolutions.com

Posts: 16,685
iTrader: (31)

Send a message via AIM to Jeff@TopGearSolutions
Quote:
Originally Posted by raceyBMW View Post
The old ones yes, but I don't know if anyone can say that about the new electric water pumps. They don't seem to be too prevalent...yet.

Seems the 328's and 330's have them fail just as much as the 335's, so I don't think its a problem with being tuned. For the OP's case, very possible you just got a bad unit, or maybe another side issue that's causing it to work too hard and prematurely failing.
Well def the old models. But its common practice for the N54 especially the early 2007 models to have overheating and cooling issues.

They later updated the equipment and software but there is still an inherent flaw in BMW cooling all around. My .02

I never had any other car with cooling problems, only BMW's.
Jeff@TopGearSolutions is offline   United_States
0
Reply With Quote
      11-21-2011, 03:30 PM   #11
rismo
Captain
 
Drives: BMW E92 335
Join Date: Jul 2008
Location: Europe

Posts: 838
iTrader: (0)

I have had as much waterpumps as HPFP.... and my climate is not extreme hot...

BMW and Car = love
BMW and pumps = bad news...
__________________
BMW 335 E92 08 - Full options - RIP
BMW 335 E92 09 - Full options - DKG - Procede Rev 3 - Vishnu Meth and Chargepipe - Forge Diverter Valves - Vishnu Flex Fuel Kit- AR Catless DP - Afe Intake - Helix IC - Ar Oil Cooler - PPK Water Cooler - M3 Suspension - JRZ RS1 Shocks - Eibach Pro Springs - Drexler LSD - BMW IS Exhaust - EBC Yellow Brake Pads - Stainless Steel Brake Lines - M101 Wheels - Michelin PSS - M-Tech Body - M-Strutbar
rismo is offline  
0
Reply With Quote
      11-21-2011, 05:59 PM   #12
Zeph
Major
 
Drives: 2008 E92 335i 6MT SGM CR/BD
Join Date: Jul 2008
Location: Southeast USA

Posts: 1,403
iTrader: (0)

Send a message via AIM to Zeph Send a message via Yahoo to Zeph
They guy who owns the dyno where I go... his wife drives a 335i and she had to have hers replaced as well. She is totally stock and doesn't drive hard. Hers is a 2007; having said that, I believe I have only heard of failures on 2007 model 335i's. He said the one he put on looked the same but had a different part or model number (or something like that).

Zeph
Zeph is offline   United_States
0
Reply With Quote
      11-21-2011, 06:04 PM   #13
GeorgiaTech335coupe
Lieutenant Colonel
 
Drives: Black BMW 335i coupe
Join Date: Mar 2007
Location: USA

Posts: 1,884
iTrader: (0)

I have an 2008 model (October 2007 build) and had my water pump fail around 40k miles. It gave no signs or codes prior. I'm FBO. currently at 51k and haven't had any more issues with it.
__________________
Legal Disclaimer: Anything I or anyone else says about my vehicle on this website(e90post.com or any affiliated or nonaffiliated sites), pertaining to modifications, is only to gain acceptance from my/our peers, and does not actually represent anything actually existing on my car, and thus, cannot be held against me in any issues, i.e. warranty claims, that may arise.
GeorgiaTech335coupe is offline  
0
Reply With Quote
      11-21-2011, 06:32 PM   #14
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: 917-939-4980
Join Date: Jun 2007
Location: New York

Posts: 18,266
iTrader: (5)

Send a message via Yahoo to cn555ic
Hmmm maybe it is a defective 2007 part but OP just replaced his and it already failed. Wonder if he got a old stock pump.
__________________

Coding E and F New York 917-939-4980
cn555ic is offline   United_States
0
Reply With Quote
      11-21-2011, 06:42 PM   #15
samchoi604
Colonel
 
Drives: black on black
Join Date: Mar 2009
Location: Burnaby, BC

Posts: 2,316
iTrader: (3)

what year is your 335i? Have oil cooler?

Ever done a coolant change? I think the aggressive/race map makes the pump run harder too.
samchoi604 is offline  
0
Reply With Quote
      11-21-2011, 09:57 PM   #16
import36
Burrito bowl connoisseur
 
import36's Avatar
 
Drives: E92 335i MT, E46 M3 SMG
Join Date: Feb 2008
Location: Seven Cities

Posts: 3,428
iTrader: (1)

Garage List
2008 BMW 335i Coupe  [4.50]
2005 BMW M3  [5.00]
Quote:
Originally Posted by samchoi604 View Post
what year is your 335i? Have oil cooler?

Ever done a coolant change? I think the aggressive/race map makes the pump run harder too.
mine is a 08'....FEB 08 build date....and i do have stock oil cooler.

coolant change was done less than a 1k miles ago when the water pump failed the first time. i'm hoping i just got a bad pump...otherwise i have no idea what the issue is. i was at the track end of Oct running the Cobb Race map...and the car ran flawlessly. for daily driving i run the Stg 2+ FMIC Agressive. at the time of the first failure....i was running a Procede.
__________________
Mods: Procede Rev3 9-10|AE Catless Dual Exhaust|AR Design Catless DPs|AMS FMIC|Stett Charge Pipe w/Tial BOV|Stett CAI|BMS OCC|BMS CDV|Volk TE37 SLs|KW V2 Coilovers|Cusco OS Strut Brace|Macht Schnell Stud Conversion|Work RS-R Lugnuts|Gloss Black Roof|Matte Black Kidney Grills|UED Lower Bumper Grills|OEM Aero Lip and Painted Reflectors|M3 Sideskirts| VRS Decklid Aero Spoiler|Gloss Black Roof|M Peformance Alcantara Steering Wheel(blue)|OSS V2.0 LED Angel Eyes|8000k HID Fog Lights|8000k MTEC Xenons
import36 is offline   United_States
0
Reply With Quote
      11-21-2011, 09:59 PM   #17
samchoi604
Colonel
 
Drives: black on black
Join Date: Mar 2009
Location: Burnaby, BC

Posts: 2,316
iTrader: (3)

Quote:
Originally Posted by import36 View Post
mine is a 08'....FEB 08 build date....and i do have stock oil cooler.

coolant change was done less than a 1k miles ago when the water pump failed the first time. i'm hoping i just got a bad pump...otherwise i have no idea what the issue is. i was at the track end of Oct running the Cobb Race map...and the car ran flawlessly. for daily driving i run the Stg 2+ FMIC Agressive. at the time of the first failure....i was running a Procede.
I see. I'm 90% sure you got a bad pump. BMW refurbishes these parts (like turbos and fuel pumps) so it is not unlikely that the part is flawed.
samchoi604 is offline  
0
Reply With Quote
      11-21-2011, 10:45 PM   #18
Mike@N54Tuning.com
BimmerPost Supporting Vendor

 
Drives: 07335i
Join Date: Dec 2008
Location: Earth

Posts: 14,442
iTrader: (86)

I am still on my original and have over 100K

Mike
Mike@N54Tuning.com is offline   Canada
0
Reply With Quote
      11-21-2011, 11:02 PM   #19
jlcolon2001
Second Lieutenant
 
Drives: 335i Coupe 2007
Join Date: May 2011
Location: Puerto Rico

Posts: 200
iTrader: (0)

I replaced the water pump and thermostat 2 weeks ago. My car is a E92 2007, no oil cooler, 39k miles aprox. with DCI and JB4. It overheated and threw 3 ECU codes, 2E81, 2E82 and 2E83.
jlcolon2001 is offline   Puerto Rico
0
Reply With Quote
      11-22-2011, 01:45 AM   #20
Mahhvinn
EUROPROJEKTZ
 
Mahhvinn's Avatar
 
Drives: backwards
Join Date: Dec 2008
Location: San Jose, CA (Bay Area)

Posts: 7,902
iTrader: (15)

Garage List
2008 E90 335i  [3.50]
I'm at 59k and my water pump went out last week. I had Injen DCI and RSD Charge pipe w/ HKS BOV and Vanguard exhaust.
__________________
LTMW|SPEEDELEMENT|EUROPROJEKTZ

#TeamStretchNPoke
Mahhvinn is offline   United_States
0
Reply With Quote
      11-22-2011, 10:21 AM   #21
BlueLion
she likes the flavor......
 
Drives: A51-E92
Join Date: Nov 2006
Location: Bradenton - FL

Posts: 1,618
iTrader: (4)

Garage List
2007 BMW 335  [0.50]
ive got an 07 with 60K miles with the stock oil cooler no water pump issues
__________________

E92 Montego Blue silfa718 ..::STETT CAI|ADVAN RS|WAGNER FMIC|MS DP|VANGUARD|PROCEDE|FORGE DV|BMS OCC|KWV2|MICHELIN PSS|OOS::..

BlueLion is offline   United_States
0
Reply With Quote
      01-29-2013, 10:07 AM   #22
GRLPWR
Lieutenant
 
GRLPWR's Avatar
 
Drives: '07 335i
Join Date: Aug 2010
Location: Durham, NC

Posts: 488
iTrader: (0)

Garage List
2007 335i  [0.00]
Quote:
Originally Posted by Mike@N54Tuning.com View Post
I am still on my original and have over 100K Mike
Awesome!

Reviving an old thread, but just to add mine (for newbies).... Mine's an '07 E90, just about to turn 98k, temp indicator came on yellow, turned red w/limp, then turned yellow, then went away. Threw codes 2E81,82,83. Taking it in today assuming I'll get a new pump and hopefully new thermostat (if warranty will cover). I'll have a newly rebuilt car in no time - just had vanos unit, cam ledge bearings, vanos solenoid - exhaust side - replaced a week ago and rear pass. door window regulator a week prior to that. Git 'er dun before warranty expires! lol
GRLPWR is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:26 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST