E90Post
 


GT Haus
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > **Lag Problems??**



Reply
 
Thread Tools Search this Thread
      11-23-2011, 10:17 PM   #1
balgopi
AC Milan Rossenari
 
Drives: 2007 328i Sedan
Join Date: Jan 2011
Location: U.S.A

Posts: 141
iTrader: (0)

**Lag Problems??**

I have a 07 328i with about 57xxx miles on it.

Recently(last 3mos) it has been lagging when I accelerate and slow down(braking). It will rev down when I break and also when I accelerate it will lag and it feels like the car is stopping and then shifting by itself to the next gear.

Its an automatic transmission and I have been using the sports drive on it, but ever since these issues I have kept it in drive and nothing else.

Is it my fuel injectors that need to be cleaned or something else?
balgopi is offline  
0
Reply With Quote
      11-23-2011, 10:29 PM   #2
fdriller9
Banned
 
Drives: '06 AW 330xi
Join Date: Mar 2009
Location: North Jersey/Philly/NYC

Posts: 7,090
iTrader: (4)

Garage List
2006 330xi  [3.22]
I think you're feeling NIC, neutral idle control, kick in. Basically the car disconnects the drivetrain from the engine to reduce load and increase fuel economy. When you come to a stop, you'll feel a slight push. When you start up, it feels like a tug.

It's sucks. It was horribly implemented by BMW. They release a revised version with a software update and I got it but it's still noticeable and annoying.

You can code out NIC but fuel economy suffers.

Try resetting your throttle adaptation. Put your car into ACC power mode, which is 2 clicks of the start button, foot off brake. Then hold the accelerator down for 30-45 seconds.
fdriller9 is offline   United_States
0
Reply With Quote
      11-23-2011, 10:31 PM   #3
balgopi
AC Milan Rossenari
 
Drives: 2007 328i Sedan
Join Date: Jan 2011
Location: U.S.A

Posts: 141
iTrader: (0)

^^^are you asking me to reset the transmission?

And will this harm my engine/transmission if I do this?

(sorry, I'm not under warranty so I'm hesitant to do this)
balgopi is offline  
0
Reply With Quote
      11-23-2011, 10:45 PM   #4
fdriller9
Banned
 
Drives: '06 AW 330xi
Join Date: Mar 2009
Location: North Jersey/Philly/NYC

Posts: 7,090
iTrader: (4)

Garage List
2006 330xi  [3.22]
No I'm asking you to reset your throttle adaptation. Our cars adapt to driver habits. If you have a heavy foot, the pedal will more sensitive. If you drive slow, the pedal will be less sensitive.

It's perfectly safe to do. Your car will "relearn" your driving habits within a few days. When you first start driving around, your pedal will be more sensitive.
fdriller9 is offline   United_States
0
Reply With Quote
      11-23-2011, 10:54 PM   #5
balgopi
AC Milan Rossenari
 
Drives: 2007 328i Sedan
Join Date: Jan 2011
Location: U.S.A

Posts: 141
iTrader: (0)

thank you for your help. I will try this.

If it doesnt solve the problem, is it worth paying BMW $200 to get my fuel injectors cleaned or it wont do anything? lol
balgopi is offline  
0
Reply With Quote
      11-24-2011, 06:01 PM   #6
mlifxs
Diamond Geezer
 
mlifxs's Avatar
 
Drives: Jet Black 2007 328i Saloon
Join Date: Nov 2007
Location: Florida

Posts: 1,559
iTrader: (0)

Garage List
I had a similar issue when my car had around 40k miles. Dealer suggested fuel injection cleaning and it did correct the hesitation. It cost around $200.

They also suggested I stick with bmw recommended gas, which at the time, coincided with gas listed on toptiergas.com. I've been using Shell 93 since then.

Was it worth it? Yes, for me, since it corrected the problem.

Is there a cheaper way to correct the issue? Maybe.

You might try adding Techron when your tank is near empty, then add about a half tank of gas.
mlifxs is offline  
0
Reply With Quote
      11-25-2011, 02:30 AM   #7
balgopi
AC Milan Rossenari
 
Drives: 2007 328i Sedan
Join Date: Jan 2011
Location: U.S.A

Posts: 141
iTrader: (0)

I'll try the fuel injector clean


I always use Chevron with techron supreme when I fill up my tank...
balgopi is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:01 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST