E90Post
 


PYSPEED
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > 2011 BMW 328i - iPhone 4 USB Integration Issues



Reply
 
Thread Tools Search this Thread
      11-28-2011, 05:53 PM   #1
hshah603
Registered
 
Drives: 2011 BMW 328i
Join Date: Nov 2011
Location: United States

Posts: 3
iTrader: (0)

2011 BMW 328i - iPhone 4 USB Integration Issues

Hi everyone. I just recently bought a 2011 328i. My first BMW after driving various Toyota / Lexus vehicles for the last 8-10 years.

I have been trying to connect my iPhone to the car via USB so that I can play Spotify through the car speakers. I have a iPhone 4. I first tried a random Belkin iPhone cord (USB only), then tried an official Apple cord and finally purchased and tried the official BMW cord (with both USB + Aux).

Each time I had the exact same issue. I plug it in, go to the "External Devices" section, see my iPhone Name connected with USB, click on it, have Spotify up and playing on the phone. First I get a message saying "this device is not optimized for this iPhone," press "dismiss" and then all seems OK. Press play in Spotify and I hear the sound OK for about 20 seconds and then it goes out and I no longer see my iPhone connected in "External Devices" (the option gets grayed out). This back and forth connecting and then dropping connection happens over and over, each time I unplug and re-plug it in.

The same occurs if I use Pandora instead of Spotify.

I have a iPhone 4. Just installed iOS5 this morning and have not tried this since. Maybe iOS5 will solve this issue, but I'm not sure since it was working for a few seconds even without upgrading to iOS5.

Any thoughts, suggestions, ideas are much appreciated.

Thanks!
hshah603 is offline  
0
Reply With Quote
      11-28-2011, 05:57 PM   #2
Ron1n
Speed Demon
 
Ron1n's Avatar
 
Drives: '10 335d E90
Join Date: Oct 2009
Location: The 858

Posts: 3,248
iTrader: (4)

Garage List
2010 335d  [5.00]
Sounds like you have 6FL (underneath your armrest should be a USB port and a standard headphone jack).

If you don't, or even if you do, try using a standard AUX cable plugged into your phone, and when going to sources, select AUX and see if that works for you.
__________________
Ron1n is offline   United_States
0
Reply With Quote
      11-28-2011, 06:08 PM   #3
matrix76
Major
 
matrix76's Avatar
 
Drives: 2011 E90 328i xDrive Ex/Ps
Join Date: Sep 2009
Location: The West Coast, BC

Posts: 1,300
iTrader: (1)

BMW INTERFACE CABLE FOR IPOD IPHONE 3G 3GS 4 AUX/CHARGE


http://www.ebay.com/itm/BMW-INTERFAC...item336842644e
matrix76 is offline   Canada
0
Reply With Quote
      11-28-2011, 06:09 PM   #4
hshah603
Registered
 
Drives: 2011 BMW 328i
Join Date: Nov 2011
Location: United States

Posts: 3
iTrader: (0)

Quote:
Originally Posted by Ron1n View Post
Sounds like you have 6FL (underneath your armrest should be a USB port and a standard headphone jack).

If you don't, or even if you do, try using a standard AUX cable plugged into your phone, and when going to sources, select AUX and see if that works for you.
Thanks for the quick reply! I didn't know what "6FL" meant, but yes, these connections are in the center armrest console, so I believe I do have 6FL. I haven't tried AUX only and will definitely give that a try.

I guess even if that works, this constant connections drop via USB+AUX will still bother me and I will still want to get some closure there. It's annoying because it does seem to work fine for 20-30 seconds and then just drops and loses any recognition that a iPhone is plugged in.
hshah603 is offline  
0
Reply With Quote
      11-28-2011, 06:16 PM   #5
Ron1n
Speed Demon
 
Ron1n's Avatar
 
Drives: '10 335d E90
Join Date: Oct 2009
Location: The 858

Posts: 3,248
iTrader: (4)

Garage List
2010 335d  [5.00]
Quote:
Originally Posted by hshah603 View Post
Thanks for the quick reply! I didn't know what "6FL" meant, but yes, these connections are in the center armrest console, so I believe I do have 6FL. I haven't tried AUX only and will definitely give that a try.

I guess even if that works, this constant connections drop via USB+AUX will still bother me and I will still want to get some closure there. It's annoying because it does seem to work fine for 20-30 seconds and then just drops and loses any recognition that a iPhone is plugged in.
I can tell you that I have a 4S, running iOS5, and a '10 with 6FL, and streaming Pandora/Spotify, etc, works on my phone, so I know that 6FL is capable (and the version you have *should* be the same version I have. If you paid for 6FL, it should work, but there was a lot of discussion about the 6FL cables and them working properly/charging our phones. Can you see what the model # is on your cable, just for grins?
__________________
Ron1n is offline   United_States
0
Reply With Quote
      11-28-2011, 06:30 PM   #6
hshah603
Registered
 
Drives: 2011 BMW 328i
Join Date: Nov 2011
Location: United States

Posts: 3
iTrader: (0)

Quote:
Originally Posted by Ron1n View Post
I can tell you that I have a 4S, running iOS5, and a '10 with 6FL, and streaming Pandora/Spotify, etc, works on my phone, so I know that 6FL is capable (and the version you have *should* be the same version I have. If you paid for 6FL, it should work, but there was a lot of discussion about the 6FL cables and them working properly/charging our phones. Can you see what the model # is on your cable, just for grins?
Here we go. Part # 61-12-0-440-812 and then it says 0 440 796 on the cord itself. Good to know that it works for you and with a newer iPhone too. I'm sure it will end up being a silly issue and will work out, but it's so far no luck. Thanks again!
hshah603 is offline  
0
Reply With Quote
      11-28-2011, 06:42 PM   #7
PINeely
Lieutenant Colonel
 
Drives: 2009 E90 N54
Join Date: Jul 2009
Location: Jackson, MS

Posts: 1,548
iTrader: (0)

I actually had my 6FL cable work flawlessly for months before this same thing happened. I bought a replacement OEM cable and it did exactly as you described; 20-30 good seconds and then it cuts out.

Drives me nuts because if I want to play from my phone I have to plug in to the auxiliary jacks (can't select songs through drive this way) and if I want to use the idrive to song select I have to load a flash drive with music (can't alter contents without reconnecting to a computer).

Issue first pronounced itself on my 3G. Now I have an iPhone 4 with the new iOS and have the same issue.
__________________
PINeely is offline  
0
Reply With Quote
      11-28-2011, 06:54 PM   #8
dryicerx
First Lieutenant
 
Drives: 335is
Join Date: Jun 2010
Location: Austin, TX

Posts: 382
iTrader: (1)

Odd behavior... sounds like a bug with the iDrive software as per PINeely's comment (did you have your idrive software upgraded when this happened).

Have you tried pairing it up with bluetooth to stream the audio, and simply having it plugged in to charge it?
dryicerx is offline  
0
Reply With Quote
      11-28-2011, 07:30 PM   #9
PINeely
Lieutenant Colonel
 
Drives: 2009 E90 N54
Join Date: Jul 2009
Location: Jackson, MS

Posts: 1,548
iTrader: (0)

Quote:
Originally Posted by dryicerx View Post
Odd behavior... sounds like a bug with the iDrive software as per PINeely's comment (did you have your idrive software upgraded when this happened).

Have you tried pairing it up with bluetooth to stream the audio, and simply having it plugged in to charge it?
iDrive software was not updated prior to the issue. It just happened one day about halfway to work.

Never tried Bluetooth streaming as I thought you could only do this with the 2011 models and the i4S.
__________________
PINeely is offline  
0
Reply With Quote
      11-28-2011, 07:42 PM   #10
Braxo
New Member
 
Drives: 2005 LR3 / 2011 328xi
Join Date: Mar 2011
Location: Buffalo, NY

Posts: 27
iTrader: (0)

Unfortunately I cannot remember when I had my iPhone 4.

My iPhone 4s (with iOS5) can stream Spotify to my speakers using an iPod's USB cable.

Sometimes, I'll have Spotify playing, then I plug in the USB and select it through my non-iDrive system. At this time, the music sometimes stops as my phone's Music app opens and begins to play. I have to manually go back to Spotify and start the song again. After that, it continues to play Spotify. Perhaps it would also help to close the Music app.
__________________
2011 328i xDrive - Automatic
Twitter: @braxo
Braxo is offline  
0
Reply With Quote
      11-29-2011, 05:38 AM   #11
brentb
Enlisted Member
 
Drives: 2011 328i
Join Date: Apr 2010
Location: Ontario, Canada

Posts: 40
iTrader: (0)

I believe the USB connection is used for playing music through the iPod app only. Why not just plug an audio cable from the headphone jack into the jack on the car. Then select aux instead of iPod from the stereo. Don't expect the radio or steering wheel controls to do anything but adjust the volume though.
brentb is offline   Canada
0
Reply With Quote
      12-26-2011, 12:38 PM   #12
Brenzo
Private
 
Brenzo's Avatar
 
Drives: 2015 M235i xDrive
Join Date: Dec 2011
Location: Chicago, IL

Posts: 73
iTrader: (0)

When I try playing Spotify on my iPhone4 over the USB (2011 328xi), it will play for 20-30 seconds and then stop until I hit "play" again in the app. However, it'll stop playing just a few seconds later and I can't get it to consistently play. Not sure if having a jailbroken phone is causing the issue.

I have tried the Music Controls Pro jailbreak app, but that did not solve the problem. My only other thought is seeing if the new iDrive update that supposedly was pushed to dealerships last week can fix my problem.
Brenzo is offline   United_States
0
Reply With Quote
      03-21-2012, 10:00 AM   #13
SpartanGA
First Lieutenant
 
Drives: TBD
Join Date: Feb 2007
Location: Atlanta, GA

Posts: 388
iTrader: (0)

Quote:
Originally Posted by brentb View Post
I believe the USB connection is used for playing music through the iPod app only. Why not just plug an audio cable from the headphone jack into the jack on the car. Then select aux instead of iPod from the stereo. Don't expect the radio or steering wheel controls to do anything but adjust the volume though.
I bet this is the best post. the ipod integration is most likely designed for browsing thru the music on your iphone, not playing music from apps.

the aux cable should work, you just wont be able to skip songs...I normally just listen to whatever shuffles up in the app I am playing anyway.
SpartanGA is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Tags
2011, 328i coupe, iphone 4

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:40 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST