E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > brake pad sensor light still on!



Reply
 
Thread Tools Search this Thread
      11-11-2011, 10:18 PM   #1
muvaside
Second Lieutenant
muvaside's Avatar
United_States
8
Rep
268
Posts

 
Drives: E90 335i
Join Date: Mar 2007
Location: SoCal

iTrader: (3)

Send a message via AIM to muvaside
brake pad sensor light still on!

I just finished installing new pads,rotors and new sensors still cant reset the brake light!Has anyone encountered same problem?
Appreciate 0
      11-12-2011, 01:18 AM   #2
EconVaughn
New Member
United_States
0
Rep
5
Posts

 
Drives: '07 N52N E92 6MT Sport Saddle
Join Date: Sep 2010
Location: Visalia, CA

iTrader: (0)

Quote:
Originally Posted by muvaside View Post
I just finished installing new pads,rotors and new sensors still cant reset the brake light!Has anyone encountered same problem?
I'm having a similar problem. I noticed the sensor was broken off so I replaced it. there is plenty of pad left. but the sensor sticks out way further than the pad. super frustrating. I'm going to try
Appreciate 0
      11-12-2011, 12:04 PM   #3
subieworx
Lieutenant
7
Rep
403
Posts

 
Drives: 07 335
Join Date: Jun 2010
Location: Ohio

iTrader: (1)

I just wired the sensor out of the equation. Stupid thing drives me crazy when swapping pads back and forth for the track. All you have to do is connect the two wires and it keeps the light from coming on.
Appreciate 0
      11-18-2011, 08:26 PM   #4
muvaside
Second Lieutenant
muvaside's Avatar
United_States
8
Rep
268
Posts

 
Drives: E90 335i
Join Date: Mar 2007
Location: SoCal

iTrader: (3)

Send a message via AIM to muvaside
Follow up:Finally the sensor light turned off after letting me reset.Problem was my rear sensor was not plugged in all the way.
Appreciate 0
      11-29-2011, 03:57 PM   #5
Admir328xiCT
Private First Class
4
Rep
104
Posts

 
Drives: 2007 BMW 328xi
Join Date: Sep 2011
Location: Central Area of CT

iTrader: (0)

Quote:
Originally Posted by muvaside View Post
I just finished installing new pads,rotors and new sensors still cant reset the brake light!Has anyone encountered same problem?
For future reference - you have to replace the sensors with the pads or the light will stay on after you do the reset.
Appreciate 0
      11-30-2011, 12:11 AM   #6
fefo25
Second Lieutenant
3
Rep
261
Posts

 
Drives: 2006 325xi wagon
Join Date: Jul 2011
Location: NJ

iTrader: (0)

Quote:
Originally Posted by Admir328xiCT View Post
For future reference - you have to replace the sensors with the pads or the light will stay on after you do the reset.
How do you reset? I just changed my sensor and the light is still on
Appreciate 0
      12-01-2011, 12:05 AM   #7
Admir328xiCT
Private First Class
4
Rep
104
Posts

 
Drives: 2007 BMW 328xi
Join Date: Sep 2011
Location: Central Area of CT

iTrader: (0)

How do you reset? I just changed my sensor and the light is still on[/quote]

Put key in - hold down the mileage trip reset button once you see a yellow triangle appear let it go this will put u into reset mode. Not toggle thru until you find brakes front or back then hold the BC side button down it will reset.
Appreciate 0
      12-01-2011, 12:26 AM   #8
Stuart@BMRAutowerkes
BimmerPost Supporting Vendor
Stuart@BMRAutowerkes's Avatar
96
Rep
4,873
Posts


 
Drives: a black car
Join Date: Sep 2010
Location: Sydney

iTrader: (3)

I'm pretty sure the method above only resets the 'distance' part of the CBS, not the "!" symbol I'm sure people would be experiencing when the sensor isn't functioning properly.

I encountered this issue, I tried a different sensor and it works. No need to reset on iDrive or anything.
Appreciate 0
      12-06-2011, 01:04 PM   #9
Mark Modjeski
Registered
0
Rep
2
Posts

 
Drives: 2007 BMW Z4 3.0si
Join Date: Dec 2011
Location: Tampa

iTrader: (0)

BMW Z4 Brake Pad Sensor Reset

The above did not work on my 2007 Z4. What did work was to turn the key to position 2. Press and hold the S/R button until the "reset" text comes up on the bottom of the odometer screen. Very shortyly thereafter the "pad" icon went off.
Appreciate 0
      12-10-2011, 01:34 PM   #10
andy_06xi
Private
0
Rep
80
Posts

 
Drives: 2006 330xi
Join Date: Nov 2006
Location: Boston, MA

iTrader: (1)

Stalk based Reset Didn't work -- Bavarian Tech did

I recently had problems resetting my front brakes pad warning light. The brakes were fairly new -- and I had no trouble resetting the light via the stalk mechanism at the time of replacement.

But a month later I had the suspension done -- and the guys doing it must have pulled off the sensor and never put it back. It was hanging -- dragging on the road and eventually the pad warning light went off.

I didn't know the sensor was dragging and tried to reset via stalk a couple of times -- but it never 'took' (because the sensor was worn through).

Finally I pulled the wheel and saw the problem. I replaced the sensor -- but it still wouldn't reset via the stalk. The 'clock' wouldn't even cycle all the way - but just come up and then vanish.

Finally to avoid a trip to the dealer, I bought the Bavarian Tech diagnostic cable. This had no problem resetting the light.

My guess is that you only get a couple of tries to reset via the stalk -- and after that the fault 'sticks'.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:43 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST