E90Post
 


MINHS Auto Care Center
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > E90 Navigation Problem!



Reply
 
Thread Tools Search this Thread
      05-24-2005, 02:51 AM   #23
voltron1011
Colonel
 
voltron1011's Avatar
 
Drives: 2011 135i, FJR-1300
Join Date: Apr 2005
Location: Wiesbaden

Posts: 2,912
iTrader: (2)

All new cars out there (Toyota, Honda, etc) with gadgets will have bugs. That is just the nature of the beast.
voltron1011 is offline  
0
Reply With Quote
      06-04-2005, 11:11 PM   #24
haroldho
New Member
 
Drives: 1987 schwinn
Join Date: Apr 2005
Location: US

Posts: 21
iTrader: (0)

thought i'd post an update for the board.

for the past two and a half weeks i've been calling the dealership every few days to hear each time that they're still waiting to hear back from bmw and navteq. a few days ago, after my patience ran out, i let the service guy in the dealership know that if BMW has no idea what to do, then they need to at least bring in the car and start experimenting with replacing different parts. he said that there was a lot of buck passing going on at BMW, but that he would send someone over to pick up the car this week.

Last edited by haroldho; 06-05-2005 at 02:17 AM.
haroldho is offline  
0
Reply With Quote
      06-05-2005, 12:56 AM   #25
Armen52
Captain
 
Armen52's Avatar
 
Drives: 2006 330i
Join Date: Apr 2005
Location: Los Angeles, CA

Posts: 658
iTrader: (0)

Garage List
2006 330i  [0.00]
I'm sorry to hear that Harold. Keep us posted.
__________________
E90 330i delivered 6/29/2005, ZSP/ZPP/ZCW/Step, Arctic/Gray/Walnut
Armen52 is offline  
0
Reply With Quote
      06-05-2005, 07:23 AM   #26
pharding
Captain
 
Drives: '11 550i + '14 X3 28i
Join Date: Mar 2005
Location: Somewhere

Posts: 880
iTrader: (0)

Try this. In order to reset the Nav and I-Drive do the following at the same time. Press down and hold: volume control knob, cd eject button, and DVD eject button. It resets this system, if it should ever lock up or act goofy. On my 545 with Nav and I-Drive I had to do this 2 or 3 times over the course of a year. Somehow my wife locked it up twice.
__________________
14 550i Euro Del
14 X3
11 550i Euro Del
Retired: 08 550i Euro Del; 06 330i Euro Del; 04 545i Euro Del; 01 530i Euro Del
pharding is offline   United_States
0
Reply With Quote
      06-05-2005, 03:38 PM   #27
haroldho
New Member
 
Drives: 1987 schwinn
Join Date: Apr 2005
Location: US

Posts: 21
iTrader: (0)

Quote:
Originally Posted by pharding
Try this. In order to reset the Nav and I-Drive do the following at the same time. Press down and hold: volume control knob, cd eject button, and DVD eject button. It resets this system, if it should ever lock up or act goofy. On my 545 with Nav and I-Drive I had to do this 2 or 3 times over the course of a year. Somehow my wife locked it up twice.
thanks for the tip, but it didn't work. it did reboot the idrive however. hmm, i hope it didn't erase my presets.
haroldho is offline  
0
Reply With Quote
      06-07-2005, 12:31 PM   #28
johnfkitchen
First Lieutenant
 
Drives: 323is & 330i
Join Date: May 2005
Location: Eastern Massachusetts

Posts: 327
iTrader: (0)

Quote:
Originally Posted by pharding
Try this. In order to reset the Nav and I-Drive do the following at the same time. Press down and hold: volume control knob, cd eject button, and DVD eject button. It resets this system, if it should ever lock up or act goofy. On my 545 with Nav and I-Drive I had to do this 2 or 3 times over the course of a year. Somehow my wife locked it up twice.
A rose by any other name? Alt-ctrl-delete?
johnfkitchen is offline  
0
Reply With Quote
      06-10-2005, 04:59 AM   #29
haroldho
New Member
 
Drives: 1987 schwinn
Join Date: Apr 2005
Location: US

Posts: 21
iTrader: (0)

I got my car back from the dealer. Apparently it was an idrive software issue, as the car was calculating the correct coordinates from GPS, but idrive's nav software was displaying the wrong location. The shop guy didn't really go into detail about what exactly the problem was and how they fixed it, but he said they ran a bunch of diagnostics on the idrive and through that somehow they fixed the problem. I just hope the software doesn't flip out again.
haroldho is offline  
0
Reply With Quote
      06-10-2005, 06:24 AM   #30
drfluid
Second Lieutenant
 
drfluid's Avatar
 
Drives: 2006 - 330i Navi, Premium
Join Date: May 2005
Location: Walnut Creek, CA

Posts: 244
iTrader: (0)

Quote:
Originally Posted by haroldho
I got my car back from the dealer. Apparently it was an idrive software issue, as the car was calculating the correct coordinates from GPS, but idrive's nav software was displaying the wrong location. The shop guy didn't really go into detail about what exactly the problem was and how they fixed it, but he said they ran a bunch of diagnostics on the idrive and through that somehow they fixed the problem. I just hope the software doesn't flip out again.
Wow, that's a good new!
Hope it never ever go wrong again.
BTW, was the fix covered by the warranty?
__________________
330i-NAV-Premium
drfluid is offline   United_States
0
Reply With Quote
      01-16-2007, 11:36 PM   #31
Gary
Private
 
Gary's Avatar
 
Drives: 2007 Arctic 335I
Join Date: Apr 2006
Location: Norcal

Posts: 61
iTrader: (0)

Garage List
2006 330XI  [0.00]
me too

I had the same problem with my nav showing me driving in the middle of a lake 20-30 miles east of my actual location. my problem corrected itself when I shut the car off and restarted it. Haven't had it come back since. I will be interested if you find a more permanent fix in case it does decide to come back.
Gary is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:18 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST